summaryrefslogtreecommitdiff
path: root/dev-python/envisage
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/envisage
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/envisage')
-rw-r--r--dev-python/envisage/Manifest1
-rw-r--r--dev-python/envisage/envisage-4.4.0.ebuild36
-rw-r--r--dev-python/envisage/metadata.xml18
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/envisage/Manifest b/dev-python/envisage/Manifest
new file mode 100644
index 00000000000..7ce4072866a
--- /dev/null
+++ b/dev-python/envisage/Manifest
@@ -0,0 +1 @@
+DIST envisage-4.4.0.tar.gz 192529 SHA256 ce9274a1afef8e4b660344eda2b32c4aa23fa35aa61dadc33d5a85eb284270f6 SHA512 7cc8fa82ea9bfd53f1a6cc90551d97972dd4b7abe9476515ea617ab6a32d7f2f65b2815ed934633f96b0f1445b763b9350e5d0e37ed99768c9a2ca32e588f91f WHIRLPOOL a108b28877821fe7acc0841726f7357c75eeb6b2734fcec12fd7c700b5fff41b9c0bb84b47be95f0776529fb70b58481b6a2b1ec1ad70763799e58ac152286db
diff --git a/dev-python/envisage/envisage-4.4.0.ebuild b/dev-python/envisage/envisage-4.4.0.ebuild
new file mode 100644
index 00000000000..4bed58bfcd0
--- /dev/null
+++ b/dev-python/envisage/envisage-4.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# py2.6 fails testsuite horribly
+PYTHON_COMPAT=python2_7
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Extensible application framework"
+HOMEPAGE="http://code.enthought.com/projects/envisage"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/traits-4[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/traits-4[${PYTHON_USEDEP}]
+ dev-python/apptools[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+# tests are buggy version after version
+RESTRICT=test
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
diff --git a/dev-python/envisage/metadata.xml b/dev-python/envisage/metadata.xml
new file mode 100644
index 00000000000..9344c917f99
--- /dev/null
+++ b/dev-python/envisage/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription lang="en">
+ Envisage is a Python-based framework for building extensible
+ applications, that is, applications whose functionality can be
+ extended by adding "plug-ins". Envisage provides a standard
+ mechanism for features to be added to an application, whether by the
+ original developer or by someone else. In fact, when you build an
+ application using Envisage, the entire application consists
+ primarily of plug-ins. In this respect, it is similar to the Eclipse
+ and Netbeans frameworks for Java applications.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">envisage</remote-id>
+</upstream>
+</pkgmetadata>