summaryrefslogtreecommitdiff
path: root/dev-python/eunuchs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/eunuchs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/eunuchs')
-rw-r--r--dev-python/eunuchs/Manifest1
-rw-r--r--dev-python/eunuchs/eunuchs-20050320.1-r1.ebuild27
-rw-r--r--dev-python/eunuchs/files/eunuchs-20050320.1-python-2.5.patch11
-rw-r--r--dev-python/eunuchs/metadata.xml14
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/eunuchs/Manifest b/dev-python/eunuchs/Manifest
new file mode 100644
index 00000000000..ccae4e0926b
--- /dev/null
+++ b/dev-python/eunuchs/Manifest
@@ -0,0 +1 @@
+DIST eunuchs_20050320.1.tar.gz 8448 SHA256 2ca782d49b4065b37226f2a3f839e73d5d4c78d661ec9d2cf6219887135f9408 SHA512 b3272de7ac2a41c2c632aa17424dcc74ef3b6d536be5684bd54e4f22ce2d7c6546ac7b1b7cef2611f00b467780b11a30eca9c8804c0f8839a13adff6894ce88d WHIRLPOOL 7b39613719bbb0c228a7702fdfe56a96d8e90057dabb9c4a1abe56f8c590524275dc321d92f10eb78990480b12f87115d2f93c016b35c4320ea4bed2727321da
diff --git a/dev-python/eunuchs/eunuchs-20050320.1-r1.ebuild b/dev-python/eunuchs/eunuchs-20050320.1-r1.ebuild
new file mode 100644
index 00000000000..ee99e2d7835
--- /dev/null
+++ b/dev-python/eunuchs/eunuchs-20050320.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Missing manly parts of UNIX API for Python"
+HOMEPAGE="http://www.inoi.fi/open/trac/eunuchs http://pypi.python.org/pypi/python-eunuchs"
+SRC_URI="mirror://debian/pool/main/e/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ia64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-python-2.5.patch" )
+DOCS=( examples/ )
+
+python_test() {
+ ${PYTHON} examples/test-socketpair.py || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/eunuchs/files/eunuchs-20050320.1-python-2.5.patch b/dev-python/eunuchs/files/eunuchs-20050320.1-python-2.5.patch
new file mode 100644
index 00000000000..dfad7a8dce7
--- /dev/null
+++ b/dev-python/eunuchs/files/eunuchs-20050320.1-python-2.5.patch
@@ -0,0 +1,11 @@
+--- lib/eunuchs/sendmsg.c
++++ lib/eunuchs/sendmsg.c
+@@ -101,7 +101,7 @@
+ real_controllen += CMSG_SPACE(sizeof *info);
+ } else {
+ char *data;
+- int len;
++ Py_ssize_t len;
+
+ if (PyString_AsStringAndSize(rest, &data, &len))
+ return NULL; // TODO leaks
diff --git a/dev-python/eunuchs/metadata.xml b/dev-python/eunuchs/metadata.xml
new file mode 100644
index 00000000000..1bf73a68539
--- /dev/null
+++ b/dev-python/eunuchs/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ Eunuchs is a library of Python extensions that complement the
+ standard libraries in parts where full support for the UNIX API (or
+ the Linux API) is missing.
+
+ Most of the functions wrapped by Eunuchs are low-level, dirty, but
+ absolutely necessary functions for real systems programming. The aim
+ is to have the functions added to mainstream Python libraries.
+ </longdescription>
+</pkgmetadata>