summaryrefslogtreecommitdiff
path: root/dev-python/fedmsg
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-13 09:59:15 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-13 11:30:36 +1300
commit38ba232d7890c519cbdee4dd9d2cebdf8a60da14 (patch)
tree3a5a149a4fa62b36b173b7a562d1b288f42d24a5 /dev-python/fedmsg
parent143ba751150cb2c4e49eadc15722a71115c340a9 (diff)
downloadgentoo-38ba232d7890c519cbdee4dd9d2cebdf8a60da14.tar.gz
gentoo-38ba232d7890c519cbdee4dd9d2cebdf8a60da14.tar.xz
dev-python/fedmsg: Added at version 0.18.0
Configuration optimised for making anitya (https://release-monitoring.org) work out of the box: This includes disabling verification by default, as its currently impossible to get x509 verification working on Python 3.5 People who want signature verification enabled are encouraged to install for python 2.7, and RDEPEND is configured to automatically pull in m2crypto if you opt to build for python 2.7 However, getting it working will still require m2ext being added to tree somewhere, which is dubious given m2ext hasn't been touched since 2012 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/fedmsg')
-rw-r--r--dev-python/fedmsg/Manifest1
-rw-r--r--dev-python/fedmsg/fedmsg-0.18.0.ebuild36
-rw-r--r--dev-python/fedmsg/files/0.18.0-endpoints.patch39
-rw-r--r--dev-python/fedmsg/files/0.18.0-no_signatures.patch29
-rw-r--r--dev-python/fedmsg/metadata.xml11
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/fedmsg/Manifest b/dev-python/fedmsg/Manifest
new file mode 100644
index 00000000000..0b4dcf1a035
--- /dev/null
+++ b/dev-python/fedmsg/Manifest
@@ -0,0 +1 @@
+DIST fedmsg-0.18.0.tar.gz 539333 SHA256 63ae0dd33032adbadbb710f5dc6aa03c6d60807bbce43c79a64e9ce8313cf307 SHA512 a103ef1aca70ccbf2a8dcbc5832cc09116969e201fd8129ca6ad9cb2c0075fcad700c210773251740e1568346abc1109948fd123f8bde70204bc08d638ead8d5 WHIRLPOOL bf0b3b10c5cf25c7722ce8403039ffa9c6367f0b6e3336f635f53ccd61a0720026472ef193e176427889cf2210299d00db9a93213e702e7ade7d7261595a55e3
diff --git a/dev-python/fedmsg/fedmsg-0.18.0.ebuild b/dev-python/fedmsg/fedmsg-0.18.0.ebuild
new file mode 100644
index 00000000000..cb5937d1302
--- /dev/null
+++ b/dev-python/fedmsg/fedmsg-0.18.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+inherit distutils-r1
+
+DESCRIPTION="Fedora Messaging Client API"
+HOMEPAGE="http://www.fedmsg.com/ https://pypi.python.org/pypi/fedmsg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${PV}-endpoints.patch"
+ "${FILESDIR}/${PV}-no_signatures.patch" )
+RDEPEND="
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/kitchen[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/m2crypto[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /etc/
+ doins -r "${S}/fedmsg.d"
+}
diff --git a/dev-python/fedmsg/files/0.18.0-endpoints.patch b/dev-python/fedmsg/files/0.18.0-endpoints.patch
new file mode 100644
index 00000000000..857f6839b5e
--- /dev/null
+++ b/dev-python/fedmsg/files/0.18.0-endpoints.patch
@@ -0,0 +1,39 @@
+From 8bc5cbaa977b8de962f68ef84f6c8fadcb369c85 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 13 Nov 2016 09:12:20 +1300
+Subject: [PATCH 1/2] Adjust endpoints to be more suited to gentoo users
+
+---
+ fedmsg.d/endpoints.py | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/fedmsg.d/endpoints.py b/fedmsg.d/endpoints.py
+index 72c182a..c4eab16 100644
+--- a/fedmsg.d/endpoints.py
++++ b/fedmsg.d/endpoints.py
+@@ -24,15 +24,15 @@ config = dict(
+ endpoints={
+ # These are here so your local box can listen to the upstream
+ # infrastructure's bus. Cool, right? :)
+- "fedora-infrastructure": [
+- "tcp://hub.fedoraproject.org:9940",
+- #"tcp://stg.fedoraproject.org:9940",
+- ],
++ #"fedora-infrastructure": [
++ # "tcp://hub.fedoraproject.org:9940",
++ # #"tcp://stg.fedoraproject.org:9940",
++ #],
+ #"debian-infrastructure": [
+ # "tcp://fedmsg.olasd.eu:9940",
+ #],
+- #"anitya-public-relay": [
+- # "tcp://release-monitoring.org:9940",
+- #],
++ "anitya-public-relay": [
++ "tcp://release-monitoring.org:9940",
++ ],
+ },
+ )
+--
+2.10.2
+
diff --git a/dev-python/fedmsg/files/0.18.0-no_signatures.patch b/dev-python/fedmsg/files/0.18.0-no_signatures.patch
new file mode 100644
index 00000000000..8be69ad5ba8
--- /dev/null
+++ b/dev-python/fedmsg/files/0.18.0-no_signatures.patch
@@ -0,0 +1,29 @@
+From 8f61441ba94f7f0bd2b2a1c900e20db038b7085f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 13 Nov 2016 09:23:58 +1300
+Subject: [PATCH 2/2] Disable signature validation
+
+Signature validation currently requires M2Crypto and M2Ext,
+which are *only* available on Python2
+
+Python3 Implementations of Signature Validation appear currently broken
+---
+ fedmsg.d/ssl.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fedmsg.d/ssl.py b/fedmsg.d/ssl.py
+index c148667..f635ffb 100644
+--- a/fedmsg.d/ssl.py
++++ b/fedmsg.d/ssl.py
+@@ -25,7 +25,7 @@ here = os.getcwd()
+
+ config = dict(
+ sign_messages=False,
+- validate_signatures=True,
++ validate_signatures=False,
+
+ # Use these implementations to sign and validate messages
+ crypto_backend='x509',
+--
+2.10.2
+
diff --git a/dev-python/fedmsg/metadata.xml b/dev-python/fedmsg/metadata.xml
new file mode 100644
index 00000000000..7b208507f3c
--- /dev/null
+++ b/dev-python/fedmsg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>kentnl@gentoo.org</email>
+ <name>Kent Fredric</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>