summaryrefslogtreecommitdiff
path: root/dev-python/flake8
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-21 01:39:26 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-21 02:34:25 +0100
commita109f9d56891f4c943e96dc3cb1820192457484d (patch)
treec876f8a3ac8201fb1cae7521aa7cef157e0faaf6 /dev-python/flake8
parentb725237df868831487c200fd37c7833227e86caf (diff)
downloadgentoo-a109f9d56891f4c943e96dc3cb1820192457484d.tar.gz
gentoo-a109f9d56891f4c943e96dc3cb1820192457484d.tar.xz
dev-python/flake8: Version bump to 3.2.1
Gentoo-bug: 602654 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.2.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 24364278d6c..37dde0b3765 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -6,3 +6,4 @@ DIST flake8-2.5.0.tar.gz 82600 SHA256 8216c8c6ee092ae93d51f89bc91045648c88cd9be7
DIST flake8-2.5.1.tar.gz 83692 SHA256 448aed48b0671fe6062f47b98c3081f3a4b36fbe99ddb8ac2a3be6e6cb135603 SHA512 030d2464717f62e3c5501631e7bc4482321086ca3e7f7dfe845dab66aaf38be94565c1e147792ba7e7d2850fd5290e61a24fe1006daf18c3be2ff81348c5731c WHIRLPOOL 63a6915eeb32be4aa51f3b69c5c6918c3a2953a4dff203515d20a10e58dc12cf7732a5e715b279c17d2a0e4b77f6879dc9f489395ddbcb6d0c340a21be39f9e4
DIST flake8-2.5.4.tar.gz 81663 SHA256 cc1e58179f6cf10524c7bfdd378f5536d0a61497688517791639a5ecc867492f SHA512 31cbec556fc41361ac464d2547275e319ab663c907a4a8644113a2288a9f349bcfbec85197b6dfa13a7db9e82419f01e0f2abc84a347e133c144ea137e0daa28 WHIRLPOOL 2547b78092b1a85edd2a0d03d9e0bc31e7d3b7cb3958cf5dea9947377851a69d5c37f64c0d65a5d7e88ab9573597729adbe07ae758b0510e455b26bf62292f47
DIST flake8-3.0.4.tar.gz 1382588 SHA256 b4c210c998f07d6ff24325dd91fbc011f2c37bcd6bf576b188de01d8656e970d SHA512 845b38824112edfc8244f6ec795b5659f99b4e8171af5e6c737f345e5a429f7b26f57e24ccc42fa2d8117b7ceff4dd100fe840064260fa17f203804e4b83ab06 WHIRLPOOL 79300674a1a326d95e80208cee664b0ddcd518653cac2aac381a3a32c1bcc40b4ddb00f95b064e119bc7f40098240e77b16898db688b87a2571ad523eac72a44
+DIST flake8-3.2.1.tar.gz 129458 SHA256 c7c460b5aff3a2063c798a77af18ec70af3941d35a22e2e76965e3c0e0b36055 SHA512 9ccb4e13d87ae1198466f112138d5ef423f55e9af1d6ab9f14d6927bd40b9d621d1a74e0acd43b1ba4e12cae67d7671dde205c04f5760d760ca9d982655d4ebf WHIRLPOOL a4210bbc535fc6d61853c39ad44e2274963e8854eadaf4236c7edbe5dc367ea31d60f742e5f634b4b1ff0aea55a43aaebd29201cb5dcfc818e94aac4d6d34bf4
diff --git a/dev-python/flake8/flake8-3.2.1.ebuild b/dev-python/flake8/flake8-3.2.1.ebuild
new file mode 100644
index 00000000000..2ef4e59cd1a
--- /dev/null
+++ b/dev-python/flake8/flake8-3.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://bitbucket.org/tarek/flake8 https://pypi.python.org/pypi/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+IUSE="test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+LICENSE="MIT"
+SLOT="0"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' 'pypy*' )
+ >=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-1.4.0[${PYTHON_USEDEP}]
+ !~dev-python/pyflakes-1.2.0
+ !~dev-python/pyflakes-1.2.1
+ !~dev-python/pyflakes-1.2.2
+ >=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' 'python2*' pypy )
+ "
+PDEPEND="
+ >=dev-python/mccabe-0.5.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Gentoo has flake8 support restored in >=pep8-1.6.2-r1.
+ sed -i -e 's:, != 1.6.2::' setup.py || die
+ # Flake8 falsely assumes it needs pytest-runner unconditionally and will
+ # try to install it, causing sandbox violations.
+ sed -i -e "/setup_requires=\['pytest-runner'\],/d" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # The test suite assumes the presence of a tox.ini file in ${S},
+ # yet the distributed tarballs do not include that file.
+ touch "${S}/tox.ini" || die "Could not create tox.ini"
+
+ # using "test" instead of "ptr" results in name collisions
+ esetup.py ptr
+}