summaryrefslogtreecommitdiff
path: root/dev-python/flake8
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-09-12 09:22:32 +0800
committerIan Delaney <idella4@gentoo.org>2015-09-12 09:22:32 +0800
commitb581b255ba30cfed42885c2a1cd7ad94017a8144 (patch)
tree62b067749e64a7d778c86ef3d1dc09178f4dee88 /dev-python/flake8
parent5d71f464acd2dcc120c228a1ee0ef501e0b12fb1 (diff)
downloadgentoo-b581b255ba30cfed42885c2a1cd7ad94017a8144.tar.gz
gentoo-b581b255ba30cfed42885c2a1cd7ad94017a8144.tar.xz
dev-python/flake8: remove -2.4.0
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/flake8-2.4.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/flake8/flake8-2.4.0.ebuild b/dev-python/flake8/flake8-2.4.0.ebuild
deleted file mode 100644
index fb4b75030c4..00000000000
--- a/dev-python/flake8/flake8-2.4.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://bitbucket.org/tarek/flake8 https://pypi.python.org/pypi/flake8"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-LICENSE="MIT"
-SLOT="0"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND=">=dev-python/pyflakes-0.7.3[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]"
-PDEPEND=">=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${PDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # This tests requires / assumes this version is already installed.
- sed -e 's:test_register_extensions:_&:' -i flake8/tests/test_engine.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}