summaryrefslogtreecommitdiff
path: root/dev-python/futurist/futurist-0.13.0.ebuild
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-24 23:32:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-24 23:32:29 -0500
commit251cb4f1a81af4d998be29b9b3e47d644247e508 (patch)
tree1d97fad6e09c5ae01e65c7a30a0df9f1655019f3 /dev-python/futurist/futurist-0.13.0.ebuild
parentbf61c35c5965e49b6144feadc5d0a7d2601540ae (diff)
downloadgentoo-251cb4f1a81af4d998be29b9b3e47d644247e508.tar.gz
gentoo-251cb4f1a81af4d998be29b9b3e47d644247e508.tar.xz
dev-python/futurist: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/futurist/futurist-0.13.0.ebuild')
-rw-r--r--dev-python/futurist/futurist-0.13.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/futurist/futurist-0.13.0.ebuild b/dev-python/futurist/futurist-0.13.0.ebuild
new file mode 100644
index 00000000000..344104b49e7
--- /dev/null
+++ b/dev-python/futurist/futurist-0.13.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful additions to futures, from the future"
+HOMEPAGE="https://pypi.python.org/pypi/futurist http://docs.openstack.org/developer/futurist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/contextlib2-0.4.0[${PYTHON_USEDEP}]"