summaryrefslogtreecommitdiff
path: root/dev-python/git-python/git-python-1.0.0.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 14:11:18 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 15:11:07 +0200
commit8155268734b77d41d84e7f35cec48daff197c338 (patch)
tree945c71d6ef277c0aa879586880afd116f7dd2607 /dev-python/git-python/git-python-1.0.0.ebuild
parent3aec1c58e64e834cb7d3f1b268d1f3c398970abc (diff)
downloadgentoo-8155268734b77d41d84e7f35cec48daff197c338.tar.gz
gentoo-8155268734b77d41d84e7f35cec48daff197c338.tar.xz
dev-python/git-python: Clean old versions up
Diffstat (limited to 'dev-python/git-python/git-python-1.0.0.ebuild')
-rw-r--r--dev-python/git-python/git-python-1.0.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/git-python/git-python-1.0.0.ebuild b/dev-python/git-python/git-python-1.0.0.ebuild
deleted file mode 100644
index 01da03d8bd4..00000000000
--- a/dev-python/git-python/git-python-1.0.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="GitPython"
-MY_PV="${PV/_rc/.RC}"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="http://gitorious.org/git-python https://pypi.python.org/pypi/GitPython"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# Tests dont make sense without a git repo
-RESTRICT="test"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
-# is the correct entry for mock, however while RESTRICT="test"
-# there is little point in setting it since it is inactive
-S="${WORKDIR}/${MY_P}"