summaryrefslogtreecommitdiff
path: root/dev-python/git-python/git-python-2.0.5.ebuild
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-06-25 00:21:23 +0200
committerDavid Seifert <soap@gentoo.org>2016-07-02 14:35:33 +0200
commit67c31457f0cf39c67ef380176e0c87b0d5fc778f (patch)
tree90505a4173101374f1abe084215e796f148a5557 /dev-python/git-python/git-python-2.0.5.ebuild
parentff570cb1f176242760cbedec444c6135d884924c (diff)
downloadgentoo-67c31457f0cf39c67ef380176e0c87b0d5fc778f.tar.gz
gentoo-67c31457f0cf39c67ef380176e0c87b0d5fc778f.tar.xz
dev-python/git-python: version bump
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1740 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/git-python/git-python-2.0.5.ebuild')
-rw-r--r--dev-python/git-python/git-python-2.0.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/git-python/git-python-2.0.5.ebuild b/dev-python/git-python/git-python-2.0.5.ebuild
new file mode 100644
index 00000000000..74adc5c4efe
--- /dev/null
+++ b/dev-python/git-python/git-python-2.0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="http://gitorious.org/git-python https://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests dont make sense without a git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+# is the correct entry for mock, however while RESTRICT="test"
+# there is little point in setting it since it is inactive
+S="${WORKDIR}/${MY_P}"