summaryrefslogtreecommitdiff
path: root/dev-python/git-python/git-python-2.0.6.ebuild
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-18 11:50:56 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-18 11:50:56 +0200
commit62646258a1682ac7fe992e4ed21053ee85bcb64b (patch)
tree42b2c2d966ae4f110a42fa333cd582dc4c84517e /dev-python/git-python/git-python-2.0.6.ebuild
parent56a80bf0cda67569c3b09cca6d328b815217cc35 (diff)
downloadgentoo-62646258a1682ac7fe992e4ed21053ee85bcb64b.tar.gz
gentoo-62646258a1682ac7fe992e4ed21053ee85bcb64b.tar.xz
dev-python/git-python: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/git-python/git-python-2.0.6.ebuild')
-rw-r--r--dev-python/git-python/git-python-2.0.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/git-python/git-python-2.0.6.ebuild b/dev-python/git-python/git-python-2.0.6.ebuild
new file mode 100644
index 00000000000..74adc5c4efe
--- /dev/null
+++ b/dev-python/git-python/git-python-2.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="http://gitorious.org/git-python https://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests dont make sense without a git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+# is the correct entry for mock, however while RESTRICT="test"
+# there is little point in setting it since it is inactive
+S="${WORKDIR}/${MY_P}"