summaryrefslogtreecommitdiff
path: root/dev-python/glance_store
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 01:01:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 01:54:03 -0500
commit345f7b5c64450fd89b876067071066c8db479010 (patch)
tree85ad7f8e0b46e15a34bf9860402af578b93a8ffe /dev-python/glance_store
parentcb1243aee33955bf8a88239b954184e3258dc3fe (diff)
downloadgentoo-345f7b5c64450fd89b876067071066c8db479010.tar.gz
gentoo-345f7b5c64450fd89b876067071066c8db479010.tar.xz
dev-python/glance_store: bup for liberty
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/Manifest1
-rw-r--r--dev-python/glance_store/glance_store-0.9.1.ebuild48
-rw-r--r--dev-python/glance_store/metadata.xml4
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
index 652898f2279..4b3734ebaff 100644
--- a/dev-python/glance_store/Manifest
+++ b/dev-python/glance_store/Manifest
@@ -2,3 +2,4 @@ DIST glance_store-0.1.10.tar.gz 95520 SHA256 b390fea864f1398f79ab66ce99c3b868b86
DIST glance_store-0.4.0.tar.gz 103982 SHA256 cd15e9f9a08dc8d3eeaa452682c8e53423f848eaadf064c0ee8068583aa31154 SHA512 d69337a7f5b06b70ee9ff60e1672d0b16b1fb4e22a38939929df0a6b08f03f0954d60b3ffb747ed30510bca451421f3e5b7133aa574d5786e1b2ba43a80075bd WHIRLPOOL f6685e80e7cce7586a0ecf0af13b1366c1f3fa739571b4f209cf76074742031858f73335c9236806c54a03fb80ccad0c302f1ef6068baa6f6285ac73b708637c
DIST glance_store-0.5.0.tar.gz 106922 SHA256 bb088cea0f83d3335191174b3fbdd5f5b2a39ae4f6e0739b9159e883658657db SHA512 e9f036c9f19ca2f3b8ba82a288a6402c91d849409f4594c61c59c14c8575b5827cf8e072c4772f5ef610fd186037b2d3c5cbc5fb032ca02c025e58a6a59a2dfa WHIRLPOOL 1943b6a26e96a9043b99d6d9b8c9af78468d05f825812250f7c7c396977d4e76d9370fe0c3fd2043d67d519c53c5e11c7541ae4f0389179b61e083f059cc5aea
DIST glance_store-0.6.0.tar.gz 106047 SHA256 249c99818f7ebd1b3aea6c96a66e4e17351a1d9befaef885dada0483be6ee818 SHA512 065c3d68b67ce38a82f8eba29630f368bc723f2c6a34ed1c7adb2ab90f5d24c1b7f32a55c200e5b45167b26bd4d3dae5194484e9de17286cdd91685898276388 WHIRLPOOL c4553654288dc2f3f823a7fbde4ff4c2f1c97b704ff3f55069153819da64ffeb06380975a80db08a1dd33cbbc25418e233b1eadc2aee5569d125223efde69e4c
+DIST glance_store-0.9.1.tar.gz 110360 SHA256 29eb70a36b18cd9dce1f9f58b8a3c7dd69626b13a8e5a46c8f807e9d301d5f99 SHA512 60880a25cb4918ed8b4a9ee81bf6bc4b5732332dad48807b687c26917b4271d47f65dbbc3b1879db48f17efa4afe605d151a23aec7f3525621d61ee4a9751146 WHIRLPOOL c34e3aee26b7fe70ce68310a3a190f18670d266ba9942eccf3a87238dbe85063fb59935e4c9cee58d1fd88c22a918b76773994b33142fe6e0bf9e61e2fd4affc
diff --git a/dev-python/glance_store/glance_store-0.9.1.ebuild b/dev-python/glance_store/glance_store-0.9.1.ebuild
new file mode 100644
index 00000000000..ff0587c1e03
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.9.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A connection pool for python-ldap"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cinder +swift"
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
+ dev-python/enum34[$(python_gen_usedep 'python2*')]
+ >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ cinder? ( >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}] )
+ swift? (
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}]
+ )
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/ordereddict/d' requirements.txt
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/glance_store/metadata.xml b/dev-python/glance_store/metadata.xml
index eda0f16d7a2..827d5f6c5be 100644
--- a/dev-python/glance_store/metadata.xml
+++ b/dev-python/glance_store/metadata.xml
@@ -13,4 +13,8 @@
<remote-id type="pypi">glance_store</remote-id>
<remote-id type="launchpad">oslo</remote-id>
</upstream>
+ <use>
+ <flag name="cinder">adds cinder backend support</flag>
+ <flag name="swift">adds swift backend support</flag>
+ </use>
</pkgmetadata>