summaryrefslogtreecommitdiff
path: root/dev-python/glance_store
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-30 18:43:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-30 21:12:13 -0500
commitb54a183dd82914e18bd3ddaae8605e029c4ad14d (patch)
tree41edd0e616280b03be74d6e95c057720ae2678d9 /dev-python/glance_store
parent99223088f75196bb9182299927492daf5bcaaf5b (diff)
downloadgentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.gz
gentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.xz
openstack p2, newton is done, will add heat later
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/Manifest1
-rw-r--r--dev-python/glance_store/glance_store-0.18.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
index e17334d37b3..05591acf444 100644
--- a/dev-python/glance_store/Manifest
+++ b/dev-python/glance_store/Manifest
@@ -1 +1,2 @@
DIST glance_store-0.13.1.tar.gz 127250 SHA256 e2f2051ff22abaa462fdb7fe8741312de8543bba7f6f65165b9c52343ccd35fc SHA512 1625849ed35d8fec6d730790485451fd740240a6fd076ad084cd0444b5b8bfadeab82164854a9bee194f6f3cabff7c30815d5fdcd800a7d982ed8c3224e6aaec WHIRLPOOL e16ad3aef7ca1ef15ead956fa7e459a4f6259b3c7ffb0086b11aa5fe2c4034011d306df09255cf6b94bf9474861546e483147c3823d804b661244455e463a217
+DIST glance_store-0.18.0.tar.gz 126949 SHA256 56b8b33f5deb74c652bd82d781aa82459e14152a5ee5c74726f0f1545c2355a7 SHA512 f23505b0081d0bb9948a4a2550868ea9864c00604358264c826551caccb4e35cbdcfcaa1e0ed3d470fbe72250196e246b596cbb57db0e99cc49fba3e0c609e01 WHIRLPOOL a1f26bc06a19a6deb14b910813829a07726ec9408b71e4fbb854ea3a2815f872cd27dfd82ae4f84e1bf49fdf5b89ef079c8f17f24a883bbf5a2cacc218f0ce8f
diff --git a/dev-python/glance_store/glance_store-0.18.0.ebuild b/dev-python/glance_store/glance_store-0.18.0.ebuild
new file mode 100644
index 00000000000..9a4d8731d34
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.18.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for glance"
+HOMEPAGE="https://github.com/openstack/glance_store"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+cinder"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ cinder? ( >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i '/ordereddict/d' requirements.txt
+ distutils-r1_python_prepare_all
+}