summaryrefslogtreecommitdiff
path: root/dev-python/gst-python
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-08 19:12:13 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-08 19:12:42 +0100
commit1edadb0b4fdd05c1ffcbe6924b974243ad7fbe75 (patch)
tree37da9a009d98fa48a69c762b86a237336952f5ea /dev-python/gst-python
parentfe58c96bd6f41daf6d49d926528ff4782d8f95a9 (diff)
downloadgentoo-1edadb0b4fdd05c1ffcbe6924b974243ad7fbe75.tar.gz
gentoo-1edadb0b4fdd05c1ffcbe6924b974243ad7fbe75.tar.xz
dev-python/gst-python: version bump to 1.6.1
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest1
-rw-r--r--dev-python/gst-python/gst-python-1.6.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index f1ebb6b396a..cac62665c17 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -2,3 +2,4 @@ DIST gst-python-0.10.22.tar.bz2 632651 SHA256 8f26f519a5bccd770864317e098e5e307f
DIST gst-python-1.2.1.tar.bz2 410887 SHA256 8823e5a9ffc51212df412652da44dc3f2a0e23295da769de2d111c770280efd4 SHA512 ed318d94831d34687224d82b84735984b946c6f33704e6bda56847b633af06212f394b709257007cec5d3a3597b200fbe6b19eade6b76e7855e8668c5ebc270e WHIRLPOOL 959e976c5a481367eb298d24eed4b3bf125d173662ff30cf02506906c88cd369259e0f5cb2bbd31bae31c39934b4a894d2eae13a5e411301f055aef030dcebbb
DIST gst-python-1.4.0.tar.xz 350316 SHA256 b1e40c29ceb41b03f08d38aca6056054f0341d0706276326dceeec6ac8d53d3e SHA512 b970fd16a3b9d82f343fbf20642d165bff25fb815cfe20cc51db8c04c298a8fbd9b96f41811c2d26982eadf1f9a84495c70fbdad553778c68604f828e4773a94 WHIRLPOOL 248d91fc0aac1314c4f7b40866579601a8024c947a29a90b5b6c3585358984f1a50eb6d56aec26609d37fc9144fdf38d5edd7ad61364481d25b7cebfaeff1a96
DIST gst-python-1.6.0.tar.xz 368100 SHA256 60dbc7f5ac2b6655ed4a7ed2cee63ee5a525d37cb16eaa6b9df7d7dfe4e9605f SHA512 6ca7e274d6aac580aec52d2bc635ffcd1361de73324a2818632d5304d59b71111433f888d89864ee2053ddd71cddec93a1f8dfe511414bd6e3ab2f26e87bfece WHIRLPOOL ef2c990a7949fc9e39b93761f817bba195fc53f314017a7223504930913fe883a6953aa1a3bdb7f1ebd2fef110b3bc2ec6e6e53108ae96125ea8f74a0cfa23e7
+DIST gst-python-1.6.1.tar.xz 358396 SHA256 3cbe332e18fd2eaf23ddeee96c414f79ac1edc2f7d990582fa0ec5f977bd04f1 SHA512 f2df05ac3a9c4160eb785e2e750ceacdc2aaa4cef8571137d06495abbfe51a2607cfa6c66cd2722c0572153b2926bdbabcd6ddd652b99078007e02cb779eb1bc WHIRLPOOL 97b7bc4377280a96fcea38df9199389e36ef8f5782596f49101ae1e4221e9d49310c461f8e51f9e0e7f2c6aaf57d5bf5f45e783997f1b80e5b52ccf95dd499a0
diff --git a/dev-python/gst-python/gst-python-1.6.1.ebuild b/dev-python/gst-python/gst-python-1.6.1.ebuild
new file mode 100644
index 00000000000..d4659611ea7
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 python{3_3,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libxml2
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-1.6.1:1.0
+ >=media-libs/gst-plugins-base-1.6.1:1.0
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+# XXX: unittests are not ported to 1.0 yet.
+
+src_prepare() {
+ prepare_gst() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_gst
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ prune_libtool_files --modules
+ einstalldocs
+}