summaryrefslogtreecommitdiff
path: root/dev-python/gst-python
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-11 09:09:41 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-11 09:09:41 +0100
commit9de12ed3a858a53e94db76774b7257d67073fd4d (patch)
tree59d3781de5b1544b8b80ec73ffb8d2d8fb7dacc0 /dev-python/gst-python
parent4c4e476263c2737318cbfb183cecfc28331bd13f (diff)
downloadgentoo-9de12ed3a858a53e94db76774b7257d67073fd4d.tar.gz
gentoo-9de12ed3a858a53e94db76774b7257d67073fd4d.tar.xz
Revert "dev-python/gst-python: Adopt to changes in general python handling"
This reverts commit 3e0c77ac812b88cb421ec994fb852b8d7d5581a4.
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/gst-python-1.2.1.ebuild8
-rw-r--r--dev-python/gst-python/gst-python-1.4.0.ebuild8
-rw-r--r--dev-python/gst-python/gst-python-1.6.0.ebuild8
-rw-r--r--dev-python/gst-python/gst-python-1.6.1.ebuild8
4 files changed, 4 insertions, 28 deletions
diff --git a/dev-python/gst-python/gst-python-1.2.1.ebuild b/dev-python/gst-python/gst-python-1.2.1.ebuild
index eeb014cfe52..b2da6fdcd23 100644
--- a/dev-python/gst-python/gst-python-1.2.1.ebuild
+++ b/dev-python/gst-python/gst-python-1.2.1.ebuild
@@ -38,14 +38,8 @@ src_prepare() {
python_foreach_impl prepare_gst
}
-myeconf() {
- local flag
- flag="$(${PYTHON} -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS") or "")')"
- PYTHON="${EPYTHON}${flag}" econf
-}
-
src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir myeconf
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
}
src_compile() {
diff --git a/dev-python/gst-python/gst-python-1.4.0.ebuild b/dev-python/gst-python/gst-python-1.4.0.ebuild
index 80b1de32976..03861fd7efc 100644
--- a/dev-python/gst-python/gst-python-1.4.0.ebuild
+++ b/dev-python/gst-python/gst-python-1.4.0.ebuild
@@ -34,14 +34,8 @@ src_prepare() {
python_foreach_impl prepare_gst
}
-myeconf() {
- local flag
- flag="$(${PYTHON} -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS") or "")')"
- PYTHON="${EPYTHON}${flag}" econf
-}
-
src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir myeconf
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
}
src_compile() {
diff --git a/dev-python/gst-python/gst-python-1.6.0.ebuild b/dev-python/gst-python/gst-python-1.6.0.ebuild
index 81d086d622a..53128bc120a 100644
--- a/dev-python/gst-python/gst-python-1.6.0.ebuild
+++ b/dev-python/gst-python/gst-python-1.6.0.ebuild
@@ -34,14 +34,8 @@ src_prepare() {
python_foreach_impl prepare_gst
}
-myeconf() {
- local flag
- flag="$(${PYTHON} -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS") or "")')"
- PYTHON="${EPYTHON}${flag}" econf
-}
-
src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir myeconf
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
}
src_compile() {
diff --git a/dev-python/gst-python/gst-python-1.6.1.ebuild b/dev-python/gst-python/gst-python-1.6.1.ebuild
index 95d223e2ed3..d4659611ea7 100644
--- a/dev-python/gst-python/gst-python-1.6.1.ebuild
+++ b/dev-python/gst-python/gst-python-1.6.1.ebuild
@@ -35,14 +35,8 @@ src_prepare() {
python_foreach_impl prepare_gst
}
-myeconf() {
- local flag
- flag="$(${PYTHON} -c 'import sysconfig; print(sysconfig.get_config_var("ABIFLAGS") or "")')"
- PYTHON="${EPYTHON}${flag}" econf
-}
-
src_configure() {
- ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir myeconf
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
}
src_compile() {