summaryrefslogtreecommitdiff
path: root/dev-python/gst-python
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-09-18 23:41:23 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-09-19 00:43:26 +0200
commitb176c59960bc8844de14e363a6a931d5d4330a2b (patch)
tree90dfa5f24d498c6ad8d5cb13cf6079b05c3acf7c /dev-python/gst-python
parent2699f6411f9766622168d633123b6b65cf027902 (diff)
downloadgentoo-b176c59960bc8844de14e363a6a931d5d4330a2b.tar.gz
gentoo-b176c59960bc8844de14e363a6a931d5d4330a2b.tar.xz
dev-python/gst-python: version bump 1.8.2 → 1.8.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest1
-rw-r--r--dev-python/gst-python/gst-python-1.8.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index 9358e51b87d..e866cce11e4 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -3,3 +3,4 @@ DIST gst-python-1.2.1.tar.bz2 410887 SHA256 8823e5a9ffc51212df412652da44dc3f2a0e
DIST gst-python-1.4.0.tar.xz 350316 SHA256 b1e40c29ceb41b03f08d38aca6056054f0341d0706276326dceeec6ac8d53d3e SHA512 b970fd16a3b9d82f343fbf20642d165bff25fb815cfe20cc51db8c04c298a8fbd9b96f41811c2d26982eadf1f9a84495c70fbdad553778c68604f828e4773a94 WHIRLPOOL 248d91fc0aac1314c4f7b40866579601a8024c947a29a90b5b6c3585358984f1a50eb6d56aec26609d37fc9144fdf38d5edd7ad61364481d25b7cebfaeff1a96
DIST gst-python-1.6.2.tar.xz 358316 SHA256 4e763e317079f48a2d6f37bd600bc19650d61597fac9f5763dbad293f72f9125 SHA512 1793a4853aee560e32a9a29553c2730a20ee140bd241f89eb8cb16407a1ea3296ff47d21304f801b3fca140cafb1b6dd2c3574d11e851c424206cad6d3dc750e WHIRLPOOL 160c5989f9d492c41b1208600d7fb524f5ca2fb126e00f648c31328863791b990f0335b74a53f0c41a8ed8352e4ac26f19a3b99f24b0c6295e5c9257b4b89a68
DIST gst-python-1.8.2.tar.xz 370604 SHA256 4f5015239482014c16f435559a45e6c87930340b65ee04e2e6fa164c8d724d97 SHA512 c1b306f1b29933b081267628491c370e9e21ffeb08d9b8bbe031e36caf91217e5465e142c82cc98abc8fdf9678d8ab9f12c1b9b4c9693d42f7a892c9802a836f WHIRLPOOL c2a221cf9fc9821509c9a9b54368980bfea6d60cd61d533753a0ca474809bead0e5577828906d0af73b893892c13a339f6442f275fd4a431b5b2aec27b8193b3
+DIST gst-python-1.8.3.tar.xz 370524 SHA256 149e7b9c2c361832bc765d39bce004d1ffe1b330c09c42dc902ca48867e804ce SHA512 1660123c7ab8db85ee617fc2cd67fef4abac33e8fe1dc4d9e98b70612bb0bc6e9ea98702139f007c3e26d0139d655d6b43bcbc2cc9fade4156e6ee4842cd4119 WHIRLPOOL 432f67b6d224ed66b6601264a98a841e02c2c2d119cbb26f22d55b5b72f98fc2bcaaa833ed19b7251f928e7f7936888ff57251985fb87a1ffd3c887071803db9
diff --git a/dev-python/gst-python/gst-python-1.8.3.ebuild b/dev-python/gst-python/gst-python-1.8.3.ebuild
new file mode 100644
index 00000000000..57bc8b391cc
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.8.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python{3_3,3_4,3_5} )
+
+inherit eutils python-r1
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ prepare_gst() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_gst
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir econf
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ prune_libtool_files --modules
+ einstalldocs
+}