summaryrefslogtreecommitdiff
path: root/dev-python/html5lib/html5lib-0.9999999-r1.ebuild
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-18 09:39:00 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-18 09:44:48 +0100
commit57cb992a751b02459dbf70da77a0ffa0b07d22dc (patch)
treef547ef072ccd0f8eb663b986ac95534f35457065 /dev-python/html5lib/html5lib-0.9999999-r1.ebuild
parent9d3711c161ca9b752d31b3e18b8496771fa5dfdc (diff)
downloadgentoo-57cb992a751b02459dbf70da77a0ffa0b07d22dc.tar.gz
gentoo-57cb992a751b02459dbf70da77a0ffa0b07d22dc.tar.xz
dev-python/html5lib: Backport fix for lxml-3.5.0
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/html5lib/html5lib-0.9999999-r1.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-0.9999999-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/html5lib/html5lib-0.9999999-r1.ebuild b/dev-python/html5lib/html5lib-0.9999999-r1.ebuild
new file mode 100644
index 00000000000..f55b65fe2c7
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.9999999-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-lxml-3.5.0-backport.patch
+)
+
+python_test() {
+ nosetests --verbosity=3 || die "Tests fail with ${EPYTHON}"
+}