summaryrefslogtreecommitdiff
path: root/dev-python/httplib2
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-29 10:19:36 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-29 10:34:45 +0200
commitfbe6ff561b7a137fd273981ae77947d19b23fa75 (patch)
tree45b16fc8efa3fb7c6676c92347a79c5b7c9f7100 /dev-python/httplib2
parent26c137c37b86d335955831258d493803a06a5778 (diff)
downloadgentoo-fbe6ff561b7a137fd273981ae77947d19b23fa75.tar.gz
gentoo-fbe6ff561b7a137fd273981ae77947d19b23fa75.tar.xz
dev-python/httplib2: Set readable bit for egg
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/httplib2-0.9.2-r1.ebuild (renamed from dev-python/httplib2/httplib2-0.9.2.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/httplib2/httplib2-0.9.2.ebuild b/dev-python/httplib2/httplib2-0.9.2-r1.ebuild
index 78cdde8b65b..20df2842104 100644
--- a/dev-python/httplib2/httplib2-0.9.2.ebuild
+++ b/dev-python/httplib2/httplib2-0.9.2-r1.ebuild
@@ -22,6 +22,11 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
# tests connect to random remote sites
RESTRICT="test"
+python_prepare_all() {
+ chmod o+r */*egg*/* || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
if [[ ${EPYTHON} == python2.7 ]] ; then
cd python2 || die