summaryrefslogtreecommitdiff
path: root/dev-python/idna
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:22:08 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit30e1b233ff0e057048b012bc9545fbf5cd02e6a1 (patch)
treefe03c38f141963ce9819edd8d2dd928af86362ea /dev-python/idna
parentd8bc8f801eb4af17f3c8c550c9f043e215be111f (diff)
downloadgentoo-30e1b233ff0e057048b012bc9545fbf5cd02e6a1.tar.gz
gentoo-30e1b233ff0e057048b012bc9545fbf5cd02e6a1.tar.xz
dev-python/idna: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/idna')
-rw-r--r--dev-python/idna/idna-2.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/idna/idna-2.0-r1.ebuild b/dev-python/idna/idna-2.0-r1.ebuild
new file mode 100644
index 00000000000..9a53690c762
--- /dev/null
+++ b/dev-python/idna/idna-2.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="https://github.com/kjd/idna"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}