summaryrefslogtreecommitdiff
path: root/dev-python/iocapture/iocapture-0.1.2.ebuild
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 17:24:01 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 19:17:27 +0200
commit53c05903a69beb5c3f1e2667ea5862ff150c7ece (patch)
treea0dc1c2848fce4aeb96c7a370ce0a18efca88034 /dev-python/iocapture/iocapture-0.1.2.ebuild
parent848b462f18f88a2e2efa7c57c26fb89bd4dc01dd (diff)
downloadgentoo-53c05903a69beb5c3f1e2667ea5862ff150c7ece.tar.gz
gentoo-53c05903a69beb5c3f1e2667ea5862ff150c7ece.tar.xz
dev-python/iocapture: Initial import, test dep for argh
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/iocapture/iocapture-0.1.2.ebuild')
-rw-r--r--dev-python/iocapture/iocapture-0.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/iocapture/iocapture-0.1.2.ebuild b/dev-python/iocapture/iocapture-0.1.2.ebuild
new file mode 100644
index 00000000000..05b83a6e04f
--- /dev/null
+++ b/dev-python/iocapture/iocapture-0.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture stdout,stderr easily"
+HOMEPAGE="https://pypi.python.org/pypi/iocapture/"
+SRC_URI="https://github.com/oinume/iocapture/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="MIT"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}