summaryrefslogtreecommitdiff
path: root/dev-python/iso8601
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:24:37 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit2bc3d954b027c88d825a1b8756da53209ea46650 (patch)
tree31c254739fcfe8b013b5e5d9118d8df3b4887cce /dev-python/iso8601
parent02365548150d6f068ef7d5c56143476e4aea9328 (diff)
downloadgentoo-2bc3d954b027c88d825a1b8756da53209ea46650.tar.gz
gentoo-2bc3d954b027c88d825a1b8756da53209ea46650.tar.xz
dev-python/iso8601: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/iso8601')
-rw-r--r--dev-python/iso8601/iso8601-0.1.10-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/iso8601/iso8601-0.1.10-r1.ebuild b/dev-python/iso8601/iso8601-0.1.10-r1.ebuild
new file mode 100644
index 00000000000..c4f84eb7eac
--- /dev/null
+++ b/dev-python/iso8601/iso8601-0.1.10-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple module to parse ISO 8601 dates"
+HOMEPAGE="https://code.google.com/p/pyiso8601/ https://pypi.python.org/pypi/iso8601"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" -m pytest --verbose ${PN} || die "Tests fail with ${EPYTHON}"
+}