summaryrefslogtreecommitdiff
path: root/dev-python/jedi
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-02-16 15:44:41 -0500
committerTim Harder <radhermit@gentoo.org>2017-02-16 15:45:49 -0500
commit936ea48f2a0ecd9130252c424eedfe08dd29160a (patch)
treea886d34b3c763f67719140b415a9fd40f8f224a8 /dev-python/jedi
parent7cdb9364b6aff42a5f8d05e4bc258bd721a5a22c (diff)
downloadgentoo-936ea48f2a0ecd9130252c424eedfe08dd29160a.tar.gz
gentoo-936ea48f2a0ecd9130252c424eedfe08dd29160a.tar.xz
dev-python/jedi: version bump to 0.10.0
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/Manifest1
-rw-r--r--dev-python/jedi/jedi-0.10.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index 61d21b49907..05bbc883b52 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1 +1,2 @@
+DIST jedi-0.10.0.tar.gz 369482 SHA256 d6a7344df9c80562c3f62199278004ccc7c5889be9f1a6aa5abde117ec085123 SHA512 64ff10cf041a107ca709802b41d9ae27b31fc7fa6cff0efdde4c78d01351efdc1333f1a02e2b8004453574199a4651043e7c3fea7149bfe5e3f0e93c23c38320 WHIRLPOOL 298722d855ee40007cd857f9af2dbdd5266fa7b4fcd52a19d378fcefe378edf49c9a3a9f29251a99cc0091d08bc28411e2497479b52e721bffd7105db1e2ec1f
DIST jedi-0.9.0.tar.gz 334204 SHA256 3b4c19fba31bdead9ab7350fb9fa7c914c59b0a807dcdd5c00a05feb85491d31 SHA512 fa60861bde0afb63c90b0e14b252d33b68d5e83255d662ef727884c91bd530b5a76f0306965ed9620d7d42a92f177feb2524a7b088ade786fb486d62d6912e57 WHIRLPOOL a6233ed19129f129cd97778f1c01bdc1e0747ec1da3611164c50815c77ab57ca1c8d7bec824b00d105cac62d32f53981a54e72b80ddfef00a77cd9316aef94aa
diff --git a/dev-python/jedi/jedi-0.10.0.ebuild b/dev-python/jedi/jedi-0.10.0.ebuild
new file mode 100644
index 00000000000..d823335f90f
--- /dev/null
+++ b/dev-python/jedi/jedi-0.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Autocompletion library for Python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ # skip integration tests
+ rm test/test_integration* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test -v test \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}