summaryrefslogtreecommitdiff
path: root/dev-python/kafka-python/kafka-python-1.2.1.ebuild
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-17 14:22:35 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-17 14:22:50 -0500
commit7562a7eeb7bb747d29f20e12237595f5fb329fc4 (patch)
tree8134471b352191814ac60c884519aa6aacaa97d1 /dev-python/kafka-python/kafka-python-1.2.1.ebuild
parent98ddfbcd108cb055e4526c4ed85dea79ccd3b441 (diff)
downloadgentoo-7562a7eeb7bb747d29f20e12237595f5fb329fc4.tar.gz
gentoo-7562a7eeb7bb747d29f20e12237595f5fb329fc4.tar.xz
dev-python/kafka-python: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/kafka-python/kafka-python-1.2.1.ebuild')
-rw-r--r--dev-python/kafka-python/kafka-python-1.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/kafka-python/kafka-python-1.2.1.ebuild b/dev-python/kafka-python/kafka-python-1.2.1.ebuild
new file mode 100644
index 00000000000..fc2ef436e19
--- /dev/null
+++ b/dev-python/kafka-python/kafka-python-1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Kafka protocol support in Python"
+HOMEPAGE="https://github.com/dpkp/kafka-python/ https://pypi.python.org/pypi/kafka-python/"
+SRC_URI="https://github.com/dpkp/kafka-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="snappy test"
+
+RDEPEND="snappy? ( dev-python/snappy[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die "tests failed"
+}