summaryrefslogtreecommitdiff
path: root/dev-python/libvirt-python/libvirt-python-1.2.21.ebuild
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-07-09 16:03:18 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-07-09 16:03:18 -0500
commit3206fda8887e184a7578ea83a10e2f8a9615fbc1 (patch)
tree4d69ff987943ef09b560e700c898fa5fdcccb37e /dev-python/libvirt-python/libvirt-python-1.2.21.ebuild
parent499c1b526e852bb00d899c0684d60242c7926417 (diff)
downloadgentoo-3206fda8887e184a7578ea83a10e2f8a9615fbc1.tar.gz
gentoo-3206fda8887e184a7578ea83a10e2f8a9615fbc1.tar.xz
dev-python/libvirt-python: drop old 1.2.21
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/libvirt-python/libvirt-python-1.2.21.ebuild')
-rw-r--r--dev-python/libvirt-python/libvirt-python-1.2.21.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/libvirt-python/libvirt-python-1.2.21.ebuild b/dev-python/libvirt-python/libvirt-python-1.2.21.ebuild
deleted file mode 100644
index 1f38cff44f5..00000000000
--- a/dev-python/libvirt-python/libvirt-python-1.2.21.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-AUTOTOOLIZE=yes
-
-MY_P="${P/_rc/-rc}"
-
-inherit eutils distutils-r1
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
- SRC_URI=""
- KEYWORDS=""
- RDEPEND="app-emulation/libvirt:=[-python(-)]"
-else
- SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
- KEYWORDS="amd64 x86"
- RDEPEND="app-emulation/libvirt:0/${PV}"
-fi
-S="${WORKDIR}/${P%_rc*}"
-
-DESCRIPTION="libvirt Python bindings"
-HOMEPAGE="http://www.libvirt.org"
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="test"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-# testsuite is currently not included in upstream tarball
-RESTRICT="test"
-
-python_test() {
- esetup.py test
-}