summaryrefslogtreecommitdiff
path: root/dev-python/libvirt-python/libvirt-python-1.3.4.ebuild
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-05-01 13:45:24 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-05-01 14:15:04 -0500
commit9b146d56acd46538427c709608c17dfe34b43d05 (patch)
tree8581303ba6291f428166da49bfca6ea3ea5eff14 /dev-python/libvirt-python/libvirt-python-1.3.4.ebuild
parentaf621c349cb52c36d298d3715ad5b0c784836c1f (diff)
downloadgentoo-9b146d56acd46538427c709608c17dfe34b43d05.tar.gz
gentoo-9b146d56acd46538427c709608c17dfe34b43d05.tar.xz
dev-python/libvirt-python: version bump to 1.3.4, bug #580418
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/libvirt-python/libvirt-python-1.3.4.ebuild')
-rw-r--r--dev-python/libvirt-python/libvirt-python-1.3.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/libvirt-python-1.3.4.ebuild b/dev-python/libvirt-python/libvirt-python-1.3.4.ebuild
new file mode 100644
index 00000000000..cc59d1ba63b
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-1.3.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}