summaryrefslogtreecommitdiff
path: root/dev-python/libvirt-python/libvirt-python-2.2.0.ebuild
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-09-14 15:19:00 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-09-14 16:40:26 -0500
commitbeaa36d50e716ec8e454a15f2c40dfdcf45cd54d (patch)
treef1238b4783d1fb369d285894d6deca5c797e38c7 /dev-python/libvirt-python/libvirt-python-2.2.0.ebuild
parent4ca8e5e9a3bedc80c20718705a4613337da61d66 (diff)
downloadgentoo-beaa36d50e716ec8e454a15f2c40dfdcf45cd54d.tar.gz
gentoo-beaa36d50e716ec8e454a15f2c40dfdcf45cd54d.tar.xz
dev-python/libvirt-python: version bump to 2.2.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/libvirt-python/libvirt-python-2.2.0.ebuild')
-rw-r--r--dev-python/libvirt-python/libvirt-python-2.2.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/libvirt-python-2.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-2.2.0.ebuild
new file mode 100644
index 00000000000..4a025bf65e6
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-2.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}