summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler/line_profiler-9999.ebuild
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-17 16:53:34 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-17 16:53:34 +0100
commitf1e2563ea4a72f78edc31ee7a3264945fa667596 (patch)
treec7a35470dcb9608aae7147b8efdad42eebb769cb /dev-python/line_profiler/line_profiler-9999.ebuild
parent54bb8824e6151caa4a81bf30bfafc66f4f3c28d8 (diff)
downloadgentoo-f1e2563ea4a72f78edc31ee7a3264945fa667596.tar.gz
gentoo-f1e2563ea4a72f78edc31ee7a3264945fa667596.tar.xz
dev-python/line_profiler: Imported from science overlay
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/line_profiler/line_profiler-9999.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/line_profiler/line_profiler-9999.ebuild b/dev-python/line_profiler/line_profiler-9999.ebuild
new file mode 100644
index 00000000000..2b7914dee90
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/rkern/line_profiler"
+EGIT_REPO_URI="https://github.com/rkern/${PN}.git"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v "${S}"/tests/ \
+ || die "Tests failed with ${EPYTHON}"
+}