summaryrefslogtreecommitdiff
path: root/dev-python/linecache2
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:26:02 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit9df7077b7d8fc7f832f1ec4e21b1c2af9effe089 (patch)
treeec87eb9336e93085fc63498d16651cc8b7f9e3e2 /dev-python/linecache2
parent2bc3d954b027c88d825a1b8756da53209ea46650 (diff)
downloadgentoo-9df7077b7d8fc7f832f1ec4e21b1c2af9effe089.tar.gz
gentoo-9df7077b7d8fc7f832f1ec4e21b1c2af9effe089.tar.xz
dev-python/linecache2: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/linecache2')
-rw-r--r--dev-python/linecache2/linecache2-1.0.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/linecache2/linecache2-1.0.0-r1.ebuild b/dev-python/linecache2/linecache2-1.0.0-r1.ebuild
new file mode 100644
index 00000000000..6fc65336bb5
--- /dev/null
+++ b/dev-python/linecache2/linecache2-1.0.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Backports of the linecache module"
+HOMEPAGE="https://github.com/testing-cabal/linecache2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" -m unittest2 discover || die "tests failed under ${EPYTHON}"
+}