summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-3.9.0.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-05 17:47:07 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-05 18:19:41 +0200
commitfdab7fc15aa348d070a5b901c0cfb0d76975ec0d (patch)
tree7788fc644cd110ac1be23f94ba3715d21db2971c /dev-python/lit/lit-3.9.0.ebuild
parente201362dcb90bc23918d638bd0309ce7acc7fcbb (diff)
downloadgentoo-fdab7fc15aa348d070a5b901c0cfb0d76975ec0d.tar.gz
gentoo-fdab7fc15aa348d070a5b901c0cfb0d76975ec0d.tar.xz
dev-python/lit: Add 3.9.0 release
Diffstat (limited to 'dev-python/lit/lit-3.9.0.ebuild')
-rw-r--r--dev-python/lit/lit-3.9.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/lit/lit-3.9.0.ebuild b/dev-python/lit/lit-3.9.0.ebuild
new file mode 100644
index 00000000000..6e832f5649e
--- /dev/null
+++ b/dev-python/lit/lit-3.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+MY_P=llvm-${PV}
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://llvm.org/releases/${PV}/${MY_P}.src.tar.xz"
+EGIT_REPO_URI="http://llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}.src/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+python_test() {
+ ./lit.py -sv tests || die
+}