summaryrefslogtreecommitdiff
path: root/dev-python/lit
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-18 19:42:19 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-19 10:14:00 +0100
commit105ed7065c892ea7406b80ce092e9df7e694f90f (patch)
tree72591f2367b7fe2c7e8a8ce318464581ea99be30 /dev-python/lit
parent2b615b2592fa593fe94ab11ef95002be9b04f7ca (diff)
downloadgentoo-105ed7065c892ea7406b80ce092e9df7e694f90f.tar.gz
gentoo-105ed7065c892ea7406b80ce092e9df7e694f90f.tar.xz
dev-python/lit: Introduce a git snapshot of 4.0.0rc1
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-4.0.0_rc1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/lit/lit-4.0.0_rc1.ebuild b/dev-python/lit/lit-4.0.0_rc1.ebuild
new file mode 100644
index 00000000000..bb19dfb199a
--- /dev/null
+++ b/dev-python/lit/lit-4.0.0_rc1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="http://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="http://llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_40"
+EGIT_COMMIT="c329efbc3c94928fb826ed146897aada0459c983"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+S=${WORKDIR}/${P}/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+python_test() {
+ ./lit.py -sv tests || die
+}