summaryrefslogtreecommitdiff
path: root/dev-python/llvmlite
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/llvmlite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest4
-rw-r--r--dev-python/llvmlite/llvmlite-0.2.1.ebuild21
-rw-r--r--dev-python/llvmlite/llvmlite-0.2.2.ebuild21
-rw-r--r--dev-python/llvmlite/llvmlite-0.5.0.ebuild39
-rw-r--r--dev-python/llvmlite/llvmlite-0.6.0.ebuild39
-rw-r--r--dev-python/llvmlite/metadata.xml8
6 files changed, 132 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
new file mode 100644
index 00000000000..cb671e0df77
--- /dev/null
+++ b/dev-python/llvmlite/Manifest
@@ -0,0 +1,4 @@
+DIST llvmlite-0.2.1.tar.gz 67340 SHA256 48c9217db60d496ffef9d15bcb493b84757fc08b95b0332ca418a21344fd3f6b SHA512 d2b705ec275bfd6ed87b0b536eb0223d9aba53bf77227ed54b43a7efa1ea5df44a10624613bcb724a7520df77d1417b96567d41efe5825a5bde217343816263c WHIRLPOOL c59c1d5af1f8f7c22dd28d54619e6385a56e1d12fcbe4af2dd18be82ea1d841348ccd9c01b8e3efd144d5e36326b627f46a65b84e0d0bd5be789da20d3d0cb13
+DIST llvmlite-0.2.2.tar.gz 75171 SHA256 5771189d07da7774446e1ac6c586d31ea4293ef1c2bfb9dbe0c570bcf971b4a1 SHA512 7eeea5c0bd5287415d6cc39fb2e546366de42d3b2b99cf57655036c9fd2bf526398cc51ea79d062504cdfdd927ce5be22997a54c5d79cc2e4de3168317f35fcf WHIRLPOOL aac97a187e341a67a5ee1771480deb6598d921cfce098aec6ca20927d6173c1f984de0b8e1985e2c7db55e393e65f4bd471c5d57bb8fd0da21cb2ad4faf0a3dc
+DIST llvmlite-0.5.0.tar.gz 74434 SHA256 616b0f16366dd1eec197b7067f4618c6c5183db852e7f4203862c0343ebdd31c SHA512 aec69c841a8166896a6632a4204a53df1f19a42514c335a3dc21a9c7e7610c110a5d00b293d7013dfe497cc7c1e3ffbaedf0a80ee16970f5f33f0043bacd6aec WHIRLPOOL 737a53017e160a04f371e87abf24eb923f17b101d3b2394c276ae0d47787c617aa496428b268ee86301a2ed33a0a93b0b5d3fbc0fb293e295d38742d8a5b98e8
+DIST llvmlite-0.6.0.tar.gz 74834 SHA256 0ed6bbf850578dc99c06be3060a1067ea4993474392137760d1c020f7188a236 SHA512 7db3f774d7cff903e4a5a476eee3efd1c6f107443433ab47543eae4e28918a385534225a23e0cd000cfab65b5ebeb0a5c38d6b963090ee0943c65fb61879fc7b WHIRLPOOL 3bed14fef8defac3f217b9ecdb5a2b4d1c68cd9e19078292cc792f375345a87b4daf63ee9c6429954d5156e7c73b5ea85b3bff54c60f78fbc982067411f2eb40
diff --git a/dev-python/llvmlite/llvmlite-0.2.1.ebuild b/dev-python/llvmlite/llvmlite-0.2.1.ebuild
new file mode 100644
index 00000000000..ea2ddc68714
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.2.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="https://pypi.python.org/pypi/llvmlite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND="=sys-devel/llvm-3.5*:=[multitarget]"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/llvmlite/llvmlite-0.2.2.ebuild b/dev-python/llvmlite/llvmlite-0.2.2.ebuild
new file mode 100644
index 00000000000..ae0357941d4
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.2.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="https://pypi.python.org/pypi/llvmlite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="=sys-devel/llvm-3.5*:=[multitarget]"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/llvmlite/llvmlite-0.5.0.ebuild b/dev-python/llvmlite/llvmlite-0.5.0.ebuild
new file mode 100644
index 00000000000..ba86b96a9d2
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="https://pypi.python.org/pypi/llvmlite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ =sys-devel/llvm-3.5*:=[multitarget]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3)
+ "
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # disable test using installed instance to read version info
+ sed -e 's:test_version:_&:' -i llvmlite/tests/test_binding.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m "llvmlite.tests" || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/llvmlite/llvmlite-0.6.0.ebuild b/dev-python/llvmlite/llvmlite-0.6.0.ebuild
new file mode 100644
index 00000000000..6e422ed343f
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="https://pypi.python.org/pypi/llvmlite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ =sys-devel/llvm-3.6*:=[multitarget]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3)
+ "
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # disable test using installed instance to read version info
+ sed -e 's:test_version:_&:' -i llvmlite/tests/test_binding.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m "llvmlite.tests" || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/llvmlite/metadata.xml b/dev-python/llvmlite/metadata.xml
new file mode 100644
index 00000000000..a384c2f3ddc
--- /dev/null
+++ b/dev-python/llvmlite/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">llvmlite</remote-id>
+ </upstream>
+</pkgmetadata>