summaryrefslogtreecommitdiff
path: root/dev-python/llvmlite
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-04-05 19:34:13 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-04-06 07:29:29 +0200
commit756204b2bc4a2d7fc9420d41161714661760d3e8 (patch)
tree83ba56a6c184778037ed89d2320db547a2ced570 /dev-python/llvmlite
parent8992b14829111b6144da40ad581da43870fb7bb2 (diff)
downloadgentoo-756204b2bc4a2d7fc9420d41161714661760d3e8.tar.gz
gentoo-756204b2bc4a2d7fc9420d41161714661760d3e8.tar.xz
dev-python/llvmlite: Bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.10.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index 92cf6870f38..f35323c60f4 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1,3 +1,4 @@
+DIST llvmlite-0.10.0.tar.gz 92000 SHA256 b6b55e19ae2be38770299e9c73e6ae07d770e4f95313ddc8389ba45693b5f4aa SHA512 0d8a38c77dffaff649dd880ce25b227247a0c5a9fb5c63ba03578b2b8ac769605cfdded167a44f54edd3bef88997359d2d279dc6b6ebf64a4339bbdfb673fc3b WHIRLPOOL 87686021057dcb0844be6955d114e21044aad9a2e5095e1da4eb07b03b7de4bd663d174fd022dd56892fe26826b81d93ead8e775fca37dbf6bb7db21a223e4fe
DIST llvmlite-0.2.1.tar.gz 67340 SHA256 48c9217db60d496ffef9d15bcb493b84757fc08b95b0332ca418a21344fd3f6b SHA512 d2b705ec275bfd6ed87b0b536eb0223d9aba53bf77227ed54b43a7efa1ea5df44a10624613bcb724a7520df77d1417b96567d41efe5825a5bde217343816263c WHIRLPOOL c59c1d5af1f8f7c22dd28d54619e6385a56e1d12fcbe4af2dd18be82ea1d841348ccd9c01b8e3efd144d5e36326b627f46a65b84e0d0bd5be789da20d3d0cb13
DIST llvmlite-0.2.2.tar.gz 75171 SHA256 5771189d07da7774446e1ac6c586d31ea4293ef1c2bfb9dbe0c570bcf971b4a1 SHA512 7eeea5c0bd5287415d6cc39fb2e546366de42d3b2b99cf57655036c9fd2bf526398cc51ea79d062504cdfdd927ce5be22997a54c5d79cc2e4de3168317f35fcf WHIRLPOOL aac97a187e341a67a5ee1771480deb6598d921cfce098aec6ca20927d6173c1f984de0b8e1985e2c7db55e393e65f4bd471c5d57bb8fd0da21cb2ad4faf0a3dc
DIST llvmlite-0.5.0.tar.gz 74434 SHA256 616b0f16366dd1eec197b7067f4618c6c5183db852e7f4203862c0343ebdd31c SHA512 aec69c841a8166896a6632a4204a53df1f19a42514c335a3dc21a9c7e7610c110a5d00b293d7013dfe497cc7c1e3ffbaedf0a80ee16970f5f33f0043bacd6aec WHIRLPOOL 737a53017e160a04f371e87abf24eb923f17b101d3b2394c276ae0d47787c617aa496428b268ee86301a2ed33a0a93b0b5d3fbc0fb293e295d38742d8a5b98e8
diff --git a/dev-python/llvmlite/llvmlite-0.10.0.ebuild b/dev-python/llvmlite/llvmlite-0.10.0.ebuild
new file mode 100644
index 00000000000..4b8f23fe69b
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DISTUTILS_IN_SOURCE_BUILD="1"
+RESTRICT="test"
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="https://pypi.python.org/pypi/llvmlite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ =sys-devel/llvm-3.7*:=[multitarget]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3)
+ "
+DEPEND="${RDEPEND}
+ dev-util/cmake"
+
+python_prepare_all() {
+ sed -i -e 's/-flto$/-flto -fPIC/' ffi/Makefile.linux || die
+
+ # disable test using installed instance to read version info
+ sed -e 's:test_version:_&:' -i llvmlite/tests/test_binding.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m "llvmlite.tests" || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}