summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib/matplotlib-1.5.1.ebuild
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-15 13:31:54 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-15 13:32:09 +0100
commit0842291d0ea6a9c62513692c7320f0ef85e167f5 (patch)
treed9d8cf09298a9de7769ab777b5d3b9b306307761 /dev-python/matplotlib/matplotlib-1.5.1.ebuild
parente223cf2f5eeb23b476eaf2e3862b52986e8e797a (diff)
downloadgentoo-0842291d0ea6a9c62513692c7320f0ef85e167f5.tar.gz
gentoo-0842291d0ea6a9c62513692c7320f0ef85e167f5.tar.xz
dev-python/matplotlib: Backport test fix
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib/matplotlib-1.5.1.ebuild')
-rw-r--r--dev-python/matplotlib/matplotlib-1.5.1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/matplotlib/matplotlib-1.5.1.ebuild b/dev-python/matplotlib/matplotlib-1.5.1.ebuild
index 9fabf36f5dc..410effc1803 100644
--- a/dev-python/matplotlib/matplotlib-1.5.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.5.1.ebuild
@@ -110,7 +110,10 @@ RDEPEND="${COMMON_DEPEND}
# Other than that, the ebuild shall be fit for out-of-source build.
DISTUTILS_IN_SOURCE_BUILD=1
-PATCHES=( "${FILESDIR}"/${P}-test-fix-backport.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-test-fix-backport.patch
+ "${FILESDIR}"/${P}-test-fix-backport-2.patch
+ )
pkg_setup() {
unset DISPLAY # bug #278524
@@ -156,11 +159,6 @@ python_prepare_all() {
-e "s:/usr/:${EPREFIX}/usr/:g" \
-i setupext.py || die
- # https://github.com/matplotlib/matplotlib/issues/5857
- sed \
- -e 's:test_pep8_conformance_examples:_&:g' \
- -i lib/matplotlib/tests/test_coding_standards.py || die
-
export XDG_RUNTIME_DIR="${T}/runtime-dir"
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die