summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-11-10 10:17:29 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-17 19:43:33 +0100
commit5e1167894d7eb47ec8318367deb21825b71dfff2 (patch)
tree64356ba2ce8242d01dda3ceeb63206a98d19649c /dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild
parent4f5f8f7d68042af567fb58dd32f27db03c3e5aa5 (diff)
downloadgentoo-5e1167894d7eb47ec8318367deb21825b71dfff2.tar.gz
gentoo-5e1167894d7eb47ec8318367deb21825b71dfff2.tar.xz
dev-python/matplotlib2tikz: Version bump to 0.6.14
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6166
Diffstat (limited to 'dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild')
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild
new file mode 100644
index 00000000000..28505b0459e
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}