summaryrefslogtreecommitdiff
path: root/dev-python/mccabe
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-02-19 22:58:28 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2016-02-19 23:21:45 +0300
commit44195e0a9a9930fc2ceddccbba0e013a17e84042 (patch)
treeddbbe6e87fa7a22b6e61f83e4b2486d1c306ba9c /dev-python/mccabe
parent51afce0c3076b193777f71414a05beb965f1a6d7 (diff)
downloadgentoo-44195e0a9a9930fc2ceddccbba0e013a17e84042.tar.gz
gentoo-44195e0a9a9930fc2ceddccbba0e013a17e84042.tar.xz
dev-python/mccabe: use py.test to run tests
This way testsuite actually works on Python < 3.5 because pytest decorators are respected properly. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/mccabe')
-rw-r--r--dev-python/mccabe/mccabe-0.4.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-python/mccabe/mccabe-0.4.0.ebuild b/dev-python/mccabe/mccabe-0.4.0.ebuild
index 22838d6764d..f3b8516aac9 100644
--- a/dev-python/mccabe/mccabe-0.4.0.ebuild
+++ b/dev-python/mccabe/mccabe-0.4.0.ebuild
@@ -29,5 +29,5 @@ src_prepare() {
}
python_test() {
- ${EPYTHON} test_mccabe.py || die
+ py.test -v || die "Testing failed with ${EPYTHON}"
}