summaryrefslogtreecommitdiff
path: root/dev-python/nose
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-11 18:12:33 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-11 18:27:03 +0100
commitebe2b8e703d94d0fbfe184ebacdf4b069b8e9838 (patch)
treefd6d7e3b8279d5276bf597e0a412e7f801de00b2 /dev-python/nose
parent3b7f08409587f14225fc02bf95acc53e17e37afb (diff)
downloadgentoo-ebe2b8e703d94d0fbfe184ebacdf4b069b8e9838.tar.gz
gentoo-ebe2b8e703d94d0fbfe184ebacdf4b069b8e9838.tar.xz
dev-python/nose: Depend on threading support in python
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/nose-1.3.4.ebuild1
-rw-r--r--dev-python/nose/nose-1.3.6.ebuild1
-rw-r--r--dev-python/nose/nose-1.3.7.ebuild1
-rw-r--r--dev-python/nose/nose-9999.ebuild1
4 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/nose/nose-1.3.4.ebuild b/dev-python/nose/nose-1.3.4.ebuild
index 43a992ef176..61cff467b38 100644
--- a/dev-python/nose/nose-1.3.4.ebuild
+++ b/dev-python/nose/nose-1.3.4.ebuild
@@ -5,6 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
diff --git a/dev-python/nose/nose-1.3.6.ebuild b/dev-python/nose/nose-1.3.6.ebuild
index 2b9c3e05358..3c80cdd3061 100644
--- a/dev-python/nose/nose-1.3.6.ebuild
+++ b/dev-python/nose/nose-1.3.6.ebuild
@@ -5,6 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
diff --git a/dev-python/nose/nose-1.3.7.ebuild b/dev-python/nose/nose-1.3.7.ebuild
index ca246d9a9fb..117bf17411b 100644
--- a/dev-python/nose/nose-1.3.7.ebuild
+++ b/dev-python/nose/nose-1.3.7.ebuild
@@ -5,6 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
diff --git a/dev-python/nose/nose-9999.ebuild b/dev-python/nose/nose-9999.ebuild
index 785d9d3d66b..261ed7f9d52 100644
--- a/dev-python/nose/nose-9999.ebuild
+++ b/dev-python/nose/nose-9999.ebuild
@@ -11,6 +11,7 @@ inherit git-2
#endif
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 eutils
DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"