summaryrefslogtreecommitdiff
path: root/dev-python/notify-python
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/notify-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/notify-python')
-rw-r--r--dev-python/notify-python/Manifest1
-rw-r--r--dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch37
-rw-r--r--dev-python/notify-python/metadata.xml9
-rw-r--r--dev-python/notify-python/notify-python-0.1.1-r3.ebuild56
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/notify-python/Manifest b/dev-python/notify-python/Manifest
new file mode 100644
index 00000000000..281a9241d80
--- /dev/null
+++ b/dev-python/notify-python/Manifest
@@ -0,0 +1 @@
+DIST notify-python-0.1.1.tar.bz2 214514 SHA256 7d3bbb7c3d8f56c922cc31d02ef9057a4f06998cc2fd4f3119a576fcf8d504ce SHA512 67021af81d77b6a1ead4ee2a0ab4e8684c2b60c672ab7aa09a8f89d71cf646453d9be76455ac28616d70645019946db1731a7021fbb91fe66d9e057fcb3815a0 WHIRLPOOL 106e71668290ebba145cc88542aac6dbe63eebcac84f7eced68256536b9fe8f3a574bad90362e07c993fdb88df2712826d8d0aa75b7f7a3c8bf5013d3cb3263c
diff --git a/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch b/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch
new file mode 100644
index 00000000000..ee146cb6fd8
--- /dev/null
+++ b/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch
@@ -0,0 +1,37 @@
+http://pkgs.fedoraproject.org/gitweb/?p=notify-python.git;a=blob_plain;f=libnotify07.patch;hb=HEAD
+
+--- src/pynotify.defs
++++ src/pynotify.defs
+@@ -38,7 +38,6 @@
+ '("const-gchar*" "summary")
+ '("const-gchar*" "message" (null-ok) (default "NULL"))
+ '("const-gchar*" "icon" (null-ok) (default "NULL"))
+- '("GtkWidget*" "attach" (null-ok) (default "NULL"))
+ )
+ )
+
+@@ -53,24 +52,6 @@
+ )
+ )
+
+-(define-method attach_to_widget
+- (of-object "NotifyNotification")
+- (c-name "notify_notification_attach_to_widget")
+- (return-type "none")
+- (parameters
+- '("GtkWidget*" "attach")
+- )
+-)
+-
+-(define-method attach_to_status_icon
+- (of-object "NotifyNotification")
+- (c-name "notify_notification_attach_to_status_icon")
+- (return-type "none")
+- (parameters
+- '("GtkStatusIcon*" "attach")
+- )
+-)
+-
+ (define-method show
+ (of-object "NotifyNotification")
+ (c-name "notify_notification_show")
diff --git a/dev-python/notify-python/metadata.xml b/dev-python/notify-python/metadata.xml
new file mode 100644
index 00000000000..f95d435c3a6
--- /dev/null
+++ b/dev-python/notify-python/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/notify-python/notify-python-0.1.1-r3.ebuild b/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
new file mode 100644
index 00000000000..1bde31ffa4e
--- /dev/null
+++ b/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils eutils python-r1
+
+DESCRIPTION="Python bindings for libnotify"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/pygtk-2.24:2[${PYTHON_USEDEP}]
+ >=x11-libs/libnotify-0.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-libnotify-0.7.patch )
+
+src_prepare() {
+ # Remove the old pynotify.c to ensure it's properly regenerated #212128.
+ rm -f src/pynotify.c || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_test() {
+ python_foreach_impl autotools-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+ prune_libtool_files --all
+
+ # Requested from bug 351879.
+ if use examples; then
+ docinto examples
+ dodoc tests/*.{png,py}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}