summaryrefslogtreecommitdiff
path: root/dev-python/numpy
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 18:14:41 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 18:14:48 +0100
commitb48b454b3056202c949e2f72f5f088eb93057da1 (patch)
tree235908c75027fd0c1486eee54bfc8125e403da97 /dev-python/numpy
parent620b91fd054274c0935afd96f31292466e3ec698 (diff)
downloadgentoo-b48b454b3056202c949e2f72f5f088eb93057da1.tar.gz
gentoo-b48b454b3056202c949e2f72f5f088eb93057da1.tar.xz
dev-python/numpy: Properly handle f2py stuff
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=570760 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/numpy-1.10.2-r2.ebuild (renamed from dev-python/numpy/numpy-1.10.2-r1.ebuild)27
1 files changed, 13 insertions, 14 deletions
diff --git a/dev-python/numpy/numpy-1.10.2-r1.ebuild b/dev-python/numpy/numpy-1.10.2-r2.ebuild
index 9dc68cdc08f..33f693b40a1 100644
--- a/dev-python/numpy/numpy-1.10.2-r1.ebuild
+++ b/dev-python/numpy/numpy-1.10.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -105,12 +105,12 @@ python_prepare_all() {
[[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
fi
- # don't version f2py, we will handle it.
- sed -i -e '/f2py_exe/s:+os\.path.*$::' numpy/f2py/setup.py || die
+# # don't version f2py, we will handle it.
+ sed -i -e '/f2py_exe/s: + os\.path.*$::' numpy/f2py/setup.py || die
- # we don't have f2py-3.3
+# # we don't have f2py-3.3
sed \
- -e "/f2py_cmd/s:'f2py'.*:'f2py'\]:g" \
+ -e 's:test_f2py:_&:g' \
-i numpy/tests/test_scripts.py || die
distutils-r1_python_prepare_all
@@ -135,17 +135,16 @@ python_install() {
}
python_install_all() {
- distutils-r1_python_install_all
-
- dodoc COMPATIBILITY DEV_README.txt THANKS.txt
+ DOCS+=( COMPATIBILITY DEV_README.txt THANKS.txt )
if use doc; then
- dohtml -r "${WORKDIR}"/html/*
- dodoc "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf
+ HTML_DOCS=( "${WORKDIR}"/html/. )
+ DOCS+=( "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf )
fi
- # absent in 1.9
- #docinto f2py
- #dodoc numpy/f2py/docs/*.txt
- #doman numpy/f2py/f2py.1
+ distutils-r1_python_install_all
+
+ docinto f2py
+ dodoc doc/f2py/*.txt
+ doman doc/f2py/f2py.1
}