summaryrefslogtreecommitdiff
path: root/dev-python/oauthlib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/oauthlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/oauthlib')
-rw-r--r--dev-python/oauthlib/Manifest2
-rw-r--r--dev-python/oauthlib/metadata.xml9
-rw-r--r--dev-python/oauthlib/oauthlib-0.7.2.ebuild32
-rw-r--r--dev-python/oauthlib/oauthlib-1.0.1.ebuild34
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/oauthlib/Manifest b/dev-python/oauthlib/Manifest
new file mode 100644
index 00000000000..d8a8e85658e
--- /dev/null
+++ b/dev-python/oauthlib/Manifest
@@ -0,0 +1,2 @@
+DIST oauthlib-0.7.2.tar.gz 106079 SHA256 a051f04ee8ec3305055ab34d87b36c9a449375e07c7d6a05bcafa48329cac7c3 SHA512 11bcd1b0930342017c63c305029efa3cc44afb4ce786c0d0afdecc22928a9ada1356899a58e6e7332e08d1a62c3ce83889f6396234534143781635983185b974 WHIRLPOOL 55cd2df10e40e4b05518b2b830418ea8718b584348eda031a8b0281dcddf93ab5afde88a7a583bb3a0f9fd4a59272e61ff68418bb9aee469e203f0f79a01836c
+DIST oauthlib-1.0.1.tar.gz 108125 SHA256 2f1999a7c11f8714a1545de033b0950da77f651ff64f271d7dd9df15dc72049b SHA512 4592ba6a146df55451f65ceab9dd049ddaba20bb0364c4cff882450b701052afc88541e6bf2a112ee18499a9c80e3b1b5e1292899ff7c861e0042c5f96b75653 WHIRLPOOL da8dad0ece0c1f9fbe486c0c23943068612b603e708fdc3c601f19203e2301c308972a50db335804bc1797f645e6355996b7cf484490a4d187d89d337b5f45ed
diff --git a/dev-python/oauthlib/metadata.xml b/dev-python/oauthlib/metadata.xml
new file mode 100644
index 00000000000..73b1a997dc9
--- /dev/null
+++ b/dev-python/oauthlib/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">oauthlib</remote-id>
+ <remote-id type="github">idan/oauthlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oauthlib/oauthlib-0.7.2.ebuild b/dev-python/oauthlib/oauthlib-0.7.2.ebuild
new file mode 100644
index 00000000000..4530459419e
--- /dev/null
+++ b/dev-python/oauthlib/oauthlib-0.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
+HOMEPAGE="https://github.com/idan/oauthlib http://pypi.python.org/pypi/oauthlib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="test"
+
+# optional extras hard set as RDEPs. See setup.py
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ )"
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/oauthlib/oauthlib-1.0.1.ebuild b/dev-python/oauthlib/oauthlib-1.0.1.ebuild
new file mode 100644
index 00000000000..c0751e0ca67
--- /dev/null
+++ b/dev-python/oauthlib/oauthlib-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
+HOMEPAGE="https://github.com/idan/oauthlib http://pypi.python.org/pypi/oauthlib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# optional extras hard set as RDEPs. See setup.py
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' python2_7) )
+ "
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}