summaryrefslogtreecommitdiff
path: root/dev-python/os-testr
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-30 18:43:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-30 21:12:13 -0500
commitb54a183dd82914e18bd3ddaae8605e029c4ad14d (patch)
tree41edd0e616280b03be74d6e95c057720ae2678d9 /dev-python/os-testr
parent99223088f75196bb9182299927492daf5bcaaf5b (diff)
downloadgentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.gz
gentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.xz
openstack p2, newton is done, will add heat later
Diffstat (limited to 'dev-python/os-testr')
-rw-r--r--dev-python/os-testr/Manifest1
-rw-r--r--dev-python/os-testr/os-testr-0.7.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/os-testr/Manifest b/dev-python/os-testr/Manifest
index 6693b043eaf..686d158e24e 100644
--- a/dev-python/os-testr/Manifest
+++ b/dev-python/os-testr/Manifest
@@ -1 +1,2 @@
DIST os-testr-0.6.0.tar.gz 36837 SHA256 473faa5d0e9d2f1ed5a92a8b942d79af9225f496ab74d6c734ceae8104138d19 SHA512 20648c8442c7d0adc42537e8ff841ac6766fd836bbe96aca77c5e99e787a27f3e490da09676c95f49371fd491ebfaa8e986a6cd53e16f50c3c83722726ae4d2c WHIRLPOOL f54d18c101a16bc3d9d6eaeb8bf36a423d22bb0ba32cce65b9e31b4d036999aeace1bddcc89644ca8d07f1c284645b512a3e06040911123c7adbe76a6b7236c4
+DIST os-testr-0.7.0.tar.gz 37324 SHA256 d04b06fcd8ce7692946bf470c26791358fa1c90cbc3ab3b28f7904ae04d6bf1a SHA512 5787044dae27b571ef065deb0df0cf5300c702e3bb026fe93e927b5ba24dafc4e957bba2e49cba290b2d6c615172d504c662cc90a7b180aa1c6ff76b6044eea3 WHIRLPOOL 9d739b8f42ea325da3ca1b1443f8728a54fc3d5963f87d2fd22683a4a016db8b72bd0f012d9119c5537741f6c0ffe3f3da0cdd6bc59d03de3105a98d53ff2458
diff --git a/dev-python/os-testr/os-testr-0.7.0.ebuild b/dev-python/os-testr/os-testr-0.7.0.ebuild
new file mode 100644
index 00000000000..2c23d79aabf
--- /dev/null
+++ b/dev-python/os-testr/os-testr-0.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A testr wrapper to provide functionality for OpenStack projects"
+HOMEPAGE="https://pypi.python.org/pypi/os-testr https://github.com/openstack/os-testr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ sed -i '/^discover/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}