summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-04-12 09:41:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-04-12 09:41:29 -0500
commit411a5041f2cde489afb10ac10dd1ef3a1f3c2700 (patch)
tree87a47733ede67d8f211c0b25343674ae0b0afbd1 /dev-python/pbr
parent7f722ad66774dcd5baa830c076fad782302f56b3 (diff)
downloadgentoo-411a5041f2cde489afb10ac10dd1ef3a1f3c2700.tar.gz
gentoo-411a5041f2cde489afb10ac10dd1ef3a1f3c2700.tar.xz
dev-python/pbr: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-1.9.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index e57b0ea74f5..30a217f3c1b 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,2 +1,3 @@
DIST pbr-0.8.2.tar.gz 77790 SHA256 eef2ace8d65d5902582cbc9ad3b2ecff0e86a6f90ad4837d8b17d568dd9dd20e SHA512 76d7d4c97660d5a6bbe9a33498a93b32528073024520e570739c511c0138ba1af7e35139bf77ca2a94063e5979baccd6252619449d6aed546fd1331be81ab52a WHIRLPOOL d6331fcd6e7d4eb750e3285e92fd21dfdfbb054b880f954156d1e781025a0c0e1c464e0c23cad587799ceba787928af092d34071eb0a5c4595b0e8aa6db52ff0
DIST pbr-1.8.1.tar.gz 104584 SHA256 e2127626a91e6c885db89668976db31020f0af2da728924b56480fc7ccf09649 SHA512 909b3ef463787d68f75f300b483ffb7d1e54ef246ed893ab5cf84e5489e171b67b77c90a1f90259ca274eeb286a66a3f221d5e0c17df5d14d0aa263d36ba6eb4 WHIRLPOOL 69bf79cc322583b17e86ccb130894dbd5aed4b0b6c8c273c977a3a5ac79190cd15b96b28d76995021eb69c30b76bcf7e9a061c0280483da9ec0c69d33e9f0822
+DIST pbr-1.9.0.tar.gz 112455 SHA256 d7a1d4622210037f2d1cfc5b65c0a87a2fb04cc58c08c3fbaf7eabc7a1dc48fb SHA512 1be1c9d610fbde82dcd81892deef3fb7b5b1e16dad6934ff3f41e8f77108b9e807a0ceaeeb2dddabecb243719f562a9701a6bf351f370e2fca4e643e86a75664 WHIRLPOOL 6be74cd54f878b93ce0d6bdf15731bcbec378f83c971f9e1962b3ae9a2dcd72312fc750af13bbc896ef8754be54bcfde4415972af4582371de73ddd5d4e6a06f
diff --git a/dev-python/pbr/pbr-1.9.0.ebuild b/dev-python/pbr/pbr-1.9.0.ebuild
new file mode 100644
index 00000000000..64ff796cf12
--- /dev/null
+++ b/dev-python/pbr/pbr-1.9.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ <dev-python/fixtures-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+PDEPEND=""
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # This test passes when run within the source and doesn't represent a failure, but rather
+ # a gentoo sandbox constraint
+ # Rm tests that rely upon the package being already installed and fail
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -e s':test_sdist_extra_files:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -e s':test_sdist_git_extra_files:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_command_hooks:_&:' \
+ -e s':test_global_setup_hooks:_&:' \
+ -i pbr/tests/test_hooks.py || die
+ sed \
+ -e "s:test_wsgi_script_install:_&:" \
+ -i pbr/tests/test_wsgi.py || die
+ einfo "rogue tests disabled"
+ sed -i '/^hacking/d' test-requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}