summaryrefslogtreecommitdiff
path: root/dev-python/peak-rules
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/peak-rules
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/peak-rules')
-rw-r--r--dev-python/peak-rules/Manifest1
-rw-r--r--dev-python/peak-rules/metadata.xml5
-rw-r--r--dev-python/peak-rules/peak-rules-0.5.ebuild44
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/peak-rules/Manifest b/dev-python/peak-rules/Manifest
new file mode 100644
index 00000000000..6146f5de165
--- /dev/null
+++ b/dev-python/peak-rules/Manifest
@@ -0,0 +1 @@
+DIST peak-rules-0.5.tar.gz 113173 SHA256 f6883f455f231d8eb72d1fd276eaae2dd91f415ad6abd6e2ec05ba8a2b4a3d55 SHA512 7ab915641829f6366b681b4c576e7213097cbd2be76bd526fdbb4f128762c04c08ee20e3fe3ef36e1df0e544719f71c28079745c9c88f98911074da51ecfa169 WHIRLPOOL 19d7c78c6689b4af1d6386f8146cb915cfe05871d7d596ceeb4c5e35876d855644ea4783ecd7c2906e3f85191cfb9d20f47e282ccef5fabe14232d41380817fc
diff --git a/dev-python/peak-rules/metadata.xml b/dev-python/peak-rules/metadata.xml
new file mode 100644
index 00000000000..301d2207cc2
--- /dev/null
+++ b/dev-python/peak-rules/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/peak-rules/peak-rules-0.5.ebuild b/dev-python/peak-rules/peak-rules-0.5.ebuild
new file mode 100644
index 00000000000..caec4bf05ed
--- /dev/null
+++ b/dev-python/peak-rules/peak-rules-0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="PEAK-Rules"
+MY_P="${MY_PN}-${PV}a1.dev-r2713"
+
+DESCRIPTION="Generic functions and business rules support systems"
+HOMEPAGE="http://peak.telecommunity.com/ https://pypi.python.org/pypi/PEAK-Rules/"
+SRC_URI="http://peak.telecommunity.com/snapshots/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( Code-Generation.txt Criteria.txt Indexing.txt README.txt Syntax-Matching.txt )
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/bytecodeassembler-0.6[${PYTHON_USEDEP}]
+ >=dev-python/addons-0.6[${PYTHON_USEDEP}]
+ >=dev-python/extremes-1.1[${PYTHON_USEDEP}]
+ test? ( >=dev-python/importing-1.10[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ PYTHONPATH=$PYTHONPATH:"${S}"/peak/rules/ "${PYTHON}" test_rules.py \
+ && einfo "Tests passed under ${EPYTHON}" \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+src_test() {
+ # Relative import misfires for core.py during emerge
+ sed -e "s:from peak.rules.core:from core:" -i test_rules.py
+ distutils-r1_src_test
+ # Return to original statefor final install
+ sed -e "s:from core:from peak.rules.core:" -i test_rules.py
+}