summaryrefslogtreecommitdiff
path: root/dev-python/pipenv/pipenv-8.3.2.ebuild
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-02 17:27:20 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-02 17:27:31 +0000
commit0e9a0c555b4ec37f78c77a3ebcf9c1e106a04ed2 (patch)
tree22044edb4517e2d2467c9abe28a8fb4ff5c0fae1 /dev-python/pipenv/pipenv-8.3.2.ebuild
parent0223b65539529e01a82fdaf9cb6edd18b594a55c (diff)
downloadgentoo-0e9a0c555b4ec37f78c77a3ebcf9c1e106a04ed2.tar.gz
gentoo-0e9a0c555b4ec37f78c77a3ebcf9c1e106a04ed2.tar.xz
dev-python/pipenv: New package
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python/pipenv/pipenv-8.3.2.ebuild')
-rw-r--r--dev-python/pipenv/pipenv-8.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pipenv/pipenv-8.3.2.ebuild b/dev-python/pipenv/pipenv-8.3.2.ebuild
new file mode 100644
index 00000000000..dd7ad3f7639
--- /dev/null
+++ b/dev-python/pipenv/pipenv-8.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Development Workflow for Humans."
+HOMEPAGE="https://github.com/kennethreitz/pipenv https://pypi.python.org/pypi/pipenv"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# not completely packed
+# requires networking
+RESTRICT="test"
+
+python_test() {
+ py.test -v -v || die
+}