summaryrefslogtreecommitdiff
path: root/dev-python/potr
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/potr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/potr')
-rw-r--r--dev-python/potr/Manifest1
-rw-r--r--dev-python/potr/metadata.xml15
-rw-r--r--dev-python/potr/potr-1.0.1.ebuild29
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/potr/Manifest b/dev-python/potr/Manifest
new file mode 100644
index 00000000000..ad2acf77ff8
--- /dev/null
+++ b/dev-python/potr/Manifest
@@ -0,0 +1 @@
+DIST python-potr-1.0.1.zip 30200 SHA256 a8a23fc1aac1e9c97b02fe462097f54f2d247f7979f0aa8ce4d66f88f6927bac SHA512 d38f2fc68ce9f72ccee18923183f8640ee51f079da1e79e1f2f22e37383c99da7a6336a8538e28bd90b483fe8e227956ebc052e9c03aa6d7b49e9fc4e8df5281 WHIRLPOOL e0b37d8c5fe6b046a072bebcc8785a55bfba1239de193ac072bc061c58826dc8ba92d35e0e51cc8065578be07af5b272dccde5d5cb2e2506d8e7cfa029a0edf7
diff --git a/dev-python/potr/metadata.xml b/dev-python/potr/metadata.xml
new file mode 100644
index 00000000000..42b14c53258
--- /dev/null
+++ b/dev-python/potr/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a pure Python OTR implementation; it does not bind to libotr.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-potr</remote-id>
+ <remote-id type="github">python-otr/pure-python-otr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/potr/potr-1.0.1.ebuild b/dev-python/potr/potr-1.0.1.ebuild
new file mode 100644
index 00000000000..8429d9b5e06
--- /dev/null
+++ b/dev-python/potr/potr-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python OTR implementation"
+HOMEPAGE="https://github.com/python-otr/pure-python-otr"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND=">=dev-python/pycrypto-2.1[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"