summaryrefslogtreecommitdiff
path: root/dev-python/pretty-yaml
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pretty-yaml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pretty-yaml')
-rw-r--r--dev-python/pretty-yaml/Manifest2
-rw-r--r--dev-python/pretty-yaml/metadata.xml9
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-14.05.7.ebuild23
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-15.5.7.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pretty-yaml/Manifest b/dev-python/pretty-yaml/Manifest
new file mode 100644
index 00000000000..a924d8fc34b
--- /dev/null
+++ b/dev-python/pretty-yaml/Manifest
@@ -0,0 +1,2 @@
+DIST pyaml-14.05.7.tar.gz 7401 SHA256 8c1edf635edc0658d9f6cd222f175e35aecaaef1cad432b188206b71a9cdbd30 SHA512 4a977de705a85341ff817b51e29facea6029c0082cdc0d9b212748d6992a1be3c461d59a5a41f131a14c0cfc0b6db3aad9091e0ff86c05da70974fd3651eaea9 WHIRLPOOL ed5fe07b7dd686a8d460841bfcbbb326d833124f0078a7aa70a80ddd3c85fcc245d9808a2aa19676636fea3d299be986fefead3022d96f846e6a9571ae67024f
+DIST pyaml-15.5.7.tar.gz 14374 SHA256 85c44970d9bca68742faef77cb10a16d4a81be81281541c8d39c10f504042bc6 SHA512 c92250bba3bfded1a4d047940098b532989f9fe020d1e7ccdd45779260e1114c8720d9ef4d98de0abfa699807d9377e29e9ad9c979dd086456eade0fecf6f0ae WHIRLPOOL e7cb76e586f32eebb8cb56af949925030dabc81e5f2f7b1a575980b49ab020968c393739deb6b69afb98f2c4b3ef21601a43166b7ce092c1e88aa3e2e95758cf
diff --git a/dev-python/pretty-yaml/metadata.xml b/dev-python/pretty-yaml/metadata.xml
new file mode 100644
index 00000000000..4eb0ed72e47
--- /dev/null
+++ b/dev-python/pretty-yaml/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyaml</remote-id>
+ <remote-id type="github">mk-fg/pretty-yaml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pretty-yaml/pretty-yaml-14.05.7.ebuild b/dev-python/pretty-yaml/pretty-yaml-14.05.7.ebuild
new file mode 100644
index 00000000000..3bdaa75ae6b
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-14.05.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{3,4}})
+
+inherit distutils-r1
+
+MY_PN="${PN//retty-}"
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
diff --git a/dev-python/pretty-yaml/pretty-yaml-15.5.7.ebuild b/dev-python/pretty-yaml/pretty-yaml-15.5.7.ebuild
new file mode 100644
index 00000000000..5fac8288f0b
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-15.5.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{3,4}})
+
+inherit distutils-r1
+
+MY_PN="${PN//retty-}"
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/unidecode[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ "${PYTHON}" pyaml/tests/dump.py || die "tests failed under ${EPYTHON}"
+}