summaryrefslogtreecommitdiff
path: root/dev-python/ptpython/ptpython-0.22.ebuild
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-06 19:59:00 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-06 19:59:00 +0200
commitb9f2e676582e512de71a35f58d7a808984ab9972 (patch)
tree6a03051082a4d905c5e58dc5e9d5e7de69b553f0 /dev-python/ptpython/ptpython-0.22.ebuild
parent3f1f4134920338e3690cfbe92bb8c26d6df5776a (diff)
downloadgentoo-b9f2e676582e512de71a35f58d7a808984ab9972.tar.gz
gentoo-b9f2e676582e512de71a35f58d7a808984ab9972.tar.xz
dev-python/ptpython: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ptpython/ptpython-0.22.ebuild')
-rw-r--r--dev-python/ptpython/ptpython-0.22.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ptpython/ptpython-0.22.ebuild b/dev-python/ptpython/ptpython-0.22.ebuild
new file mode 100644
index 00000000000..975be6b3870
--- /dev/null
+++ b/dev-python/ptpython/ptpython-0.22.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python REPL build on top of prompt_toolkit"
+HOMEPAGE="https://pypi.python.org/pypi/ptpython/ https://github.com/jonathanslenders/ptpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/prompt_toolkit-0.50[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.9.0[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ optfeature "ipython enhanced version" dev-python/ipython
+}