summaryrefslogtreecommitdiff
path: root/dev-python/pyaes/pyaes-1.6.1.ebuild
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-09-27 04:22:42 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-09-27 04:22:42 -0400
commitad1fbb7f10812c8ada3859c63a03ce779014550b (patch)
tree22726be82f6bdf30b2bba00e409e3a64f16336c1 /dev-python/pyaes/pyaes-1.6.1.ebuild
parent51a3040d62090dd91abf7c2c2819c74ec787af1a (diff)
downloadgentoo-ad1fbb7f10812c8ada3859c63a03ce779014550b.tar.gz
gentoo-ad1fbb7f10812c8ada3859c63a03ce779014550b.tar.xz
dev-python/pyaes: version bump to 1.6.1
Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'dev-python/pyaes/pyaes-1.6.1.ebuild')
-rw-r--r--dev-python/pyaes/pyaes-1.6.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyaes/pyaes-1.6.1.ebuild b/dev-python/pyaes/pyaes-1.6.1.ebuild
new file mode 100644
index 00000000000..839a967746d
--- /dev/null
+++ b/dev-python/pyaes/pyaes-1.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+HOMEPAGE="https://pypi.python.org/pypi/pyaes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} tests/test-{aes,blockfeeder,util}.py || die
+}