summaryrefslogtreecommitdiff
path: root/dev-python/pyasn1-modules
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 01:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 08:06:35 +0200
commit5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f (patch)
treef2de3644b75e298ceeaed790daab2aa73e57d62f /dev-python/pyasn1-modules
parentd4a1e3bd5d1bce9afd703ba5231c84a3178782fd (diff)
downloadgentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.gz
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.xz
dev-python/*: Restore keywords and un-revbump for py3.5
Restore keywords that were removed unnecessarily, and collapse unnecessary revbumps on packages with added python3.5 support.
Diffstat (limited to 'dev-python/pyasn1-modules')
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild38
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild2
2 files changed, 1 insertions, 39 deletions
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild
deleted file mode 100644
index a34c654789e..00000000000
--- a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="pyasn1 modules"
-HOMEPAGE="http://pyasn1.sourceforge.net/ https://pypi.python.org/pypi/pyasn1-modules"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- echoit() { echo "$@"; "$@"; }
- local exit_status=0 test
- for test in test/*.sh; do
- PATH="${S}/tools:${PATH}" \
- echoit sh "${test}" || exit_status=1
- done
- return ${exit_status}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- insinto /usr/share/${P}
- doins -r tools
-}
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
index 5c68dd2fe0b..192da0f6a5b 100644
--- a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
+++ b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1