summaryrefslogtreecommitdiff
path: root/dev-python/pychm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pychm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pychm')
-rw-r--r--dev-python/pychm/Manifest1
-rw-r--r--dev-python/pychm/metadata.xml19
-rw-r--r--dev-python/pychm/pychm-0.8.4-r1.ebuild21
-rw-r--r--dev-python/pychm/pychm-0.8.4.ebuild24
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pychm/Manifest b/dev-python/pychm/Manifest
new file mode 100644
index 00000000000..b7cb97c1a9a
--- /dev/null
+++ b/dev-python/pychm/Manifest
@@ -0,0 +1 @@
+DIST pychm-0.8.4.tar.gz 28803 SHA256 84c99d7b28fb6862ee60a5d1d52fad0da4c95f1934e9c101d3293ee7e8b5357d SHA512 0c0c107e59ea9f5fef97a0c2869349b5e90fc9eb7a37c35e8a929eaf764c7abe5a06a389340a912b9ba2f71172f3c94a78da016707bb201bbd07bdc3feddfe0d WHIRLPOOL dd183874f116a946961cfefb9150bf8bca69570f0bd271b21023b8c1d1b25abc14ff4f1f9deaa84619344c8236034c51d77b4422277e35f8df320391a24d510c
diff --git a/dev-python/pychm/metadata.xml b/dev-python/pychm/metadata.xml
new file mode 100644
index 00000000000..9ddd1c3a5b1
--- /dev/null
+++ b/dev-python/pychm/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+The chm package provides three modules, chm, chmlib and extra, which
+provide access to the API implemented by the C library chmlib and some
+additional classes and functions. They are used to access MS-ITSS
+encoded files - Compressed Html Help files (.chm).
+</longdescription>
+ <longdescription lang="ja">
+Chmパッケージは、C言語ライブラリChmのAPI実装とそれに幾つか拡張されたクラスと関数
+にアクセスする手段のchm, chmlib, extraの3つのモジュールを提供します。MS-ITSSエン
+コード・ファイルに使われています。-- Compressed Html Help ファイル (.chm)。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">gnochm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pychm/pychm-0.8.4-r1.ebuild b/dev-python/pychm/pychm-0.8.4-r1.ebuild
new file mode 100644
index 00000000000..6386e02ecac
--- /dev/null
+++ b/dev-python/pychm/pychm-0.8.4-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the chmlib library"
+HOMEPAGE="http://gnochm.sourceforge.net/pychm.html"
+SRC_URI="mirror://sourceforge/gnochm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/chmlib"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/pychm/pychm-0.8.4.ebuild b/dev-python/pychm/pychm-0.8.4.ebuild
new file mode 100644
index 00000000000..56f6ab3414b
--- /dev/null
+++ b/dev-python/pychm/pychm-0.8.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="Python bindings for the chmlib library"
+HOMEPAGE="http://gnochm.sourceforge.net/pychm.html"
+SRC_URI="mirror://sourceforge/gnochm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-libs/chmlib"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="chm"