summaryrefslogtreecommitdiff
path: root/dev-python/pycups
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-12-09 18:47:54 +0100
committerMichał Górny <mgorny@gentoo.org>2015-12-09 20:06:47 +0100
commitb6022670668137f72552ba340f7ca19dec2a08f0 (patch)
treefc47810baf88186bced63e82eeabe474cf55fcfe /dev-python/pycups
parent53d1880d2ddfe87d3e0a458910abfae99d30dc41 (diff)
downloadgentoo-b6022670668137f72552ba340f7ca19dec2a08f0.tar.gz
gentoo-b6022670668137f72552ba340f7ca19dec2a08f0.tar.xz
dev-python/pycups: Restrict *_all() phases to py2 for USE=doc
Diffstat (limited to 'dev-python/pycups')
-rw-r--r--dev-python/pycups/pycups-1.9.73.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pycups/pycups-1.9.73.ebuild b/dev-python/pycups/pycups-1.9.73.ebuild
index 188c6f747d2..ea8a0011809 100644
--- a/dev-python/pycups/pycups-1.9.73.ebuild
+++ b/dev-python/pycups/pycups-1.9.73.ebuild
@@ -31,6 +31,10 @@ DEPEND="${RDEPEND}
REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+}
+
python_compile_all() {
if use doc; then
# we can't use Makefile since it relies on hardcoded paths