summaryrefslogtreecommitdiff
path: root/dev-python/pydns
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pydns
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pydns')
-rw-r--r--dev-python/pydns/Manifest2
-rw-r--r--dev-python/pydns/metadata.xml13
-rw-r--r--dev-python/pydns/pydns-2.3.6-r1.ebuild48
-rw-r--r--dev-python/pydns/pydns-3.1.0.ebuild42
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/pydns/Manifest b/dev-python/pydns/Manifest
new file mode 100644
index 00000000000..0736ee64c8a
--- /dev/null
+++ b/dev-python/pydns/Manifest
@@ -0,0 +1,2 @@
+DIST py3dns-3.1.0.tar.gz 29501 SHA256 124d7833fd0a6fbaebe17d093b028cfa77b155b5feab8e1c6265959a4b9e7fb7 SHA512 ba2cb397351b587539072b608f6be878066bfb317f4cca472c2d3102638432de48a25d8a6efc41a88b9f77d939fa71ffb396d1a2dfab46e8d2b431d0eb89f7a4 WHIRLPOOL 8fdd8e9c75293c86120770da8e09f093cf6b8783b87e8cd7dccbf1fe8e3dfb3aad89fd371cd1a512b83db626a4a627f21ff1a497211cfaa027d08ebc650ed53b
+DIST pydns-2.3.6.tar.gz 28220 SHA256 d3cf6fc4ec088e934cf2dd4d71080efdb5c09ae79cbb2512427eb0fc393f2417 SHA512 261598c085c7d9f7adf5ce881814e444cdcf48a946dc17db467268ab6164f6045c204507cc58eff8e6f826b9786715ad2a9e766a72193ac8666969913180954b WHIRLPOOL 76d5f6caaddbaf027e4e7677d767263c270c5fc0db6e35bfb3bc99a8c229fbb2704dbbb2a2bd5207dc9c3a2f571a8b0351a492a16dc3a3fbe0c7f5cf88a91389
diff --git a/dev-python/pydns/metadata.xml b/dev-python/pydns/metadata.xml
new file mode 100644
index 00000000000..0d0515b525a
--- /dev/null
+++ b/dev-python/pydns/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">PyDNS provides a module for performing DNS queries from python
+ applications. This was originally based on Guido van Rossum's DNS
+ library code, but has drifted further and further away from it over
+ time.</longdescription>
+ <upstream>
+ <remote-id type="pypi">pydns</remote-id>
+ <remote-id type="launchpad">py3dns</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydns/pydns-2.3.6-r1.ebuild b/dev-python/pydns/pydns-2.3.6-r1.ebuild
new file mode 100644
index 00000000000..827fa94b204
--- /dev/null
+++ b/dev-python/pydns/pydns-2.3.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for DNS (Domain Name Service)"
+HOMEPAGE="http://pydns.sourceforge.net/ http://pypi.python.org/pypi/pydns"
+SRC_URI="http://downloads.sourceforge.net/project/pydns/pydns/${P}/${P}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="2"
+KEYWORDS="amd64 hppa ~ia64 ~ppc ~sparc x86"
+IUSE="examples"
+
+DEPEND="!dev-python/pydns:0
+ virtual/libiconv"
+RDEPEND=""
+
+# Funny a dns package attempts to use the network on tests
+# Await the day that gentoo chills out on such a blanket law.
+RESTRICT=test
+
+python_prepare_all() {
+ # Fix encodings (should be utf-8 but is latin1).
+ local i
+ for i in DNS/{Lib,Type}.py; do
+ iconv -f ISO-8859-1 -t UTF-8 "${i}" > "${i}.utf8" || die
+ mv -f "${i}.utf8" "${i}" || die
+ done
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local test
+ for test in tests/{test.py,test[2-5].py,testsrv.py}
+ do
+ "${PYTHON}" $test || die
+ done
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( ./{tests,tools}/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pydns/pydns-3.1.0.ebuild b/dev-python/pydns/pydns-3.1.0.ebuild
new file mode 100644
index 00000000000..d6960bfebcc
--- /dev/null
+++ b/dev-python/pydns/pydns-3.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="${PN/py/py3}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Python DNS (Domain Name System) library"
+HOMEPAGE="https://launchpad.net/py3dns"
+SRC_URI="https://launchpad.net/${MY_PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="3"
+KEYWORDS="amd64 hppa ~ia64 ~ppc ~sparc x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+# Most if not all of the tests require network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ # Some of the tests are broken.
+ for test in tests/{test{,2,4}.py,testsrv.py}
+ do
+ "${PYTHON}" ${test} || die
+ done
+
+ "${PYTHON}" tests/test5.py example.org || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( ./{tests,tools}/. )
+ distutils-r1_python_install_all
+}