summaryrefslogtreecommitdiff
path: root/dev-python/pydns
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-21 02:42:59 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-21 11:42:17 +0100
commitf186b59fd2fd2e3913e55ab6f02b42dc3e27be51 (patch)
tree72e55ffc46ab4c4b43ddf15cd8506070cf1b316b /dev-python/pydns
parent57fcb893661f1baf5e785acd862d7d6b19ea41cb (diff)
downloadgentoo-f186b59fd2fd2e3913e55ab6f02b42dc3e27be51.tar.gz
gentoo-f186b59fd2fd2e3913e55ab6f02b42dc3e27be51.tar.xz
dev-python/pydns: add py3.5, pypy3, fix deps, tests
The files in the "tests" folder are example files, not actual tests. Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3573
Diffstat (limited to 'dev-python/pydns')
-rw-r--r--dev-python/pydns/pydns-3.1.1.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/dev-python/pydns/pydns-3.1.1.ebuild b/dev-python/pydns/pydns-3.1.1.ebuild
index be2e5bfefb5..90656e32c45 100644
--- a/dev-python/pydns/pydns-3.1.1.ebuild
+++ b/dev-python/pydns/pydns-3.1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-PYTHON_COMPAT=( python3_4 )
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} pypy3 )
inherit distutils-r1
@@ -18,25 +18,22 @@ SLOT="3"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
IUSE="examples"
-DEPEND=""
-RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# Most if not all of the tests require network access.
-RESTRICT=test
+# Tests require network access
+RESTRICT="test"
S="${WORKDIR}/${MY_P}"
python_test() {
- # Some of the tests are broken.
- for test in tests/{test{,2,4}.py,testsrv.py}
- do
- "${PYTHON}" ${test} || die
- done
-
- "${PYTHON}" tests/test5.py example.org || die
+ "${EPYTHON}" -m unittest || die "tests failed with ${EPYTHON}"
}
python_install_all() {
- use examples && local EXAMPLES=( ./{tests,tools}/. )
+ if use examples; then
+ docinto examples
+ dodoc -r tests/. tools/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
distutils-r1_python_install_all
}